[OpenSUSE] Firefox crash in TYPO3, cancel pressed in "File Upload" dialogue

RESOLVED INVALID

Status

()

Firefox
File Handling
--
critical
RESOLVED INVALID
a year ago
10 months ago

People

(Reporter: Michael, Unassigned)

Tracking

({crash})

50 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161201000000

Steps to reproduce:

OpenSuse Leap 42.2 
Kernel 4.4.36-5.1
TYPO3 7.6.13
Firefox 50.0.2

- Login to Typo3 Backend. 
- Klick on "File"-"Filelist"
(Pre-Req, maybe:)  - Create a folder in /fileadmin. 

- Klick on "Directory" icon of new folder. 
- Select "Upload files".
- Klick on "Search". 
- Klick on "Cancel" in "File Upload" Dialogue





Actual results:

--> Firefox crashes. 

Reproducible / always.


Expected results:

Dialogue should just close, last page unchanged
(Reporter)

Updated

a year ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

a year ago
Severity: normal → critical
Has STR: --- → yes
Keywords: crash
Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Hi Michael,

I tested this issue on Ubuntu 16.04 x 64 with the latest Firefox release 50.0. Login to Typo3 Backend  http://cms-next.demo.typo3.org/typo3/ with "admin" and "password" credentials, but I didn't find " Upload files " button.

Can you please provide your crash report ID from about:crashes?

Thanks.
Flags: needinfo?(michaelof)
(Reporter)

Comment 2

a year ago
Hi Roxana,


thank you very much for spending time on this issue! The TYPO3 backend demo server ha very restricted access, that's why even "admin" is not authorized to upload files.

Of course I can provide you the crash id(s):
https://crash-stats.mozilla.com/report/index/2927715e-1a67-4fb9-9b47-a9cd82161209


Kind regards,
Michael
Flags: needinfo?(michaelof)
Hi Michael,

AFAIK, I'm afraid that is not much we can do with this crash report, since we're missing symbols. It would be great if you could try to reproduce the issue on an official Mozilla build and submit a crash report from there.
Also, it is possible to provide some test credentials without restriction for upload files so I can test this on my end ?
Flags: needinfo?(michaelof)
(Reporter)

Comment 4

a year ago
Hi Roxana,

as requested I've downloaded the current Firefox release from Mozilla. Extracted in local folder. and started locally from bash. Verified with "Help"/"About Firefox" that I'm really using the original Mozilla version and not the OpenSuse packaged distribution version.

Findings:

The original Mozilla version of Firefox uses a different "File upload" "select file" dialogue than the OpenSuse version. It seems, that on OpenSuse a KDE's "Dolphin" dialogues is opened.

Screenshots attached.

I guess we can put this issue on hold for a while, I'll open an issue in OpenSuse's bugzilla with reference to this issue.
Flags: needinfo?(michaelof)
(Reporter)

Comment 5

a year ago
Created attachment 8819281 [details]
Firefox_Leap42.2.png
(Reporter)

Comment 6

a year ago
Created attachment 8819283 [details]
"File Upload" dialogue on Mozilla's version of firefox
(Reporter)

Comment 7

a year ago
Roxana,

funny :-) - No need for TYPO3 access anymore: Attachement upload here in bugzilla.mozilla.org also has the same "upload / search for files" button ("Durchsuchen" in German) as TYPO3. 

Pressing "Cancel" in this dialogue ALSO crashes firefox in OpenSuse's firefox version...
(Reporter)

Comment 8

a year ago
Reference: Bug opened for OpenSuse: https://bugzilla.opensuse.org/show_bug.cgi?id=1015998
Component: Untriaged → File Handling
Crash Signature: [@ libxul.so@0xa26d5b | libxul.so@0x1e1af67 | libxul.so@0x1cabce5 | libxul.so@0x4255cbf | libxul.so@0x2ee1c02 | libxul.so@0xd3d77e | libxul.so@0xd60075 | libxul.so@0x2ee4a13 | libxul.so@0x2ee4a13 | libxul.so@0x2ee4a13 | libxul.so@0xed4ff2 | libxul.…

Updated

10 months ago
Duplicate of this bug: 1345608
Thank you for the diagnosis.
Not much point tracking this in Mozilla's tracker as this is not Mozilla code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → INVALID
Summary: Firefox crash in TYPO3, cancel pressed in "File Upload" dialogue → [OpenSUSE] Firefox crash in TYPO3, cancel pressed in "File Upload" dialogue
Duplicate of this bug: 1350549
You need to log in before you can comment on or make changes to this bug.