Closed Bug 1322613 Opened 4 years ago Closed 4 years ago

TraceLogging: Don't compare text strings when they are already flushed

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1322614

People

(Reporter: h4writer, Assigned: h4writer)

Details

Attachments

(1 file)

Gary gave this bug by mouth and mail. I think he started creating a bug report but never reported. As a result I opened this bug. He will probably still report this and I'll mark it as a duplicate.

The issue is that in the debug checks for the start/stop entries of tracelogger we assume the old text is still available. That is not always true. In between we could have flushed that information. In that case we cannot compare the text anymore.
Attached patch PatchSplinter Review
Don't check that the text is the same, if the text is not present anymore, because we flushed that information.
Assignee: nobody → hv1989
Attachment #8817553 - Flags: review?(bbouvier)
Ha~ it is bug 1322614 and just a few minutes after you reported this. :)
Comment on attachment 8817553 [details] [diff] [review]
Patch

Review of attachment 8817553 [details] [diff] [review]:
-----------------------------------------------------------------

Yep.
Attachment #8817553 - Flags: review?(bbouvier) → review+
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1322614
You need to log in before you can comment on or make changes to this bug.