After startup, previously deleted messages appeared in the unified Inbox. And "gloda.indexer ERROR Worker 'message' cleanup function itself failed"

RESOLVED INCOMPLETE

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED INCOMPLETE
a year ago
8 months ago

People

(Reporter: TJ, Unassigned)

Tracking

45 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161129173726

Steps to reproduce:

Opened Thunderbird the other day and a lot of previously deleted messages appeared in the unified Inbox - many multiple times.  This has continued every since even after using the Repair Folder option and also deleting the respective .msi files

Also noticed that it now takes a very long time before all messages are displayed in the unified Inbox.


Actual results:

This keeps showing up in the error console

Timestamp: 12/8/2016 10:38:33 PM
Error: 2016-12-08 22:38:33	gloda.indexer	ERROR	Worker 'message' cleanup function itself failed: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgDatabase.Commit]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource:///modules/gloda/index_msg.js :: gloda_index_indexerLeaveFolder :: line 879"  data: no]

Source File: resource:///modules/gloda/log4moz.js
Line: 691


Expected results:

Inbox has become unstable.  Sometimes I launch it and it seems fine - next time it may show all recently deleted messages as new.
(Reporter)

Updated

a year ago
Severity: normal → major
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

a year ago
Created attachment 8817573 [details]
screenshot of unified Inbox showing duplicate messages which had been deleted
(Reporter)

Comment 2

a year ago
Sorry, I mentioned .msi files when I meant .msf files.  I should note each time I launch Thunderbird, different previously deleted messages show back up in the Inbox.  Sometimes just one copy, sometimes two identical copies.
TJ,
Are you still seein the problem in the last few days?

yahoo has been a mess in recent months. I don't think this is being caused by Thunderbird.
Flags: needinfo?(tjwalker_97)
(Reporter)

Comment 4

a year ago
Hi Wayne.  This had nothing to do with Yahoo as I do not check that box via Thunderbird. If I remember correctly, this started after the latest automatic update on the release version.

In the process of trying to fix the issue (compressing the boxes, Repair Folder option) - I ended up loosing years of emails that were in saved sub-folders. Since I didn't notice this until the next day, the backup of my profile file was replaced with the corrupted one.

Anyway, after I upgraded to the latest Beta version (50.0b3) the error/problem went away. So it must have been something in the latest stable version update.
What antivirus software do you use?
(Reporter)

Comment 6

a year ago
Ah, good point as it may be relevant. Prior to this bug I was using Avast Free but switched to BitDefender 2016 full version.  It has an anti-spam feature that installs a special add-on to Thunderbird.  However, the problem continued even after I disabled the add-on and set BitDefender not to perform anti-spam functions.

Interesting that the 50.0b3 version will enable the Bitdefender toolbar - but it is non-functional - none of the buttons do anything.

Comment 7

9 months ago
Does the problem reproduce if you start windows in safe mode, and then start TB in safe mode, using current beta?
- win7 https://support.microsoft.com/en-us/help/17419/windows-7-advanced-startup-options-safe-mode#start-computer-safe-mode=windows-7
Still In Windows safe mode, start thunderbird in safe mode
- https://support.mozilla.org/kb/safe-mode-thunderbird

Comment 8

9 months ago
TJ...

(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #7)
> Does the problem reproduce if you start windows in safe mode, and then start
> TB in safe mode, using current beta?
> - win7
> https://support.microsoft.com/en-us/help/17419/windows-7-advanced-startup-
> options-safe-mode#start-computer-safe-mode=windows-7
> Still In Windows safe mode, start thunderbird in safe mode
> - https://support.mozilla.org/kb/safe-mode-thunderbird
Summary: Worker 'message' cleanup function failed → After startup, previously deleted messages appeared in the unified Inbox. And "gloda.indexer ERROR Worker 'message' cleanup function itself failed"
Whiteboard: [closeme 2017-04-15]

Comment 9

8 months ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(tjwalker_97)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2017-04-15]
You need to log in before you can comment on or make changes to this bug.