Closed Bug 1322711 Opened 3 years ago Closed 3 years ago

Convert robocop and test events to bundle events

Categories

(GeckoView :: General, defect)

All
Android
defect
Not set

Tracking

(firefox53 fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: jchen, Assigned: jchen)

References

Details

Attachments

(3 files)

Make test-only events use BundleEventListener/GeckoBundle
When converting a JS object to a GeckoBundle, convert the property name
to a string if necessary, because the property name could be another
type such as an integer.
Attachment #8817706 - Flags: review?(snorp)
Convert events that are only used in robocop tests to Bundle events,
which are then used through Actions.expectGlobalEvent /
expectWindowEvent.

"Content:" prefix is added to "DOMContentLoaded" to follow the event
naming convention.

SelectionHandlerTest.java is removed because it's no longer used
anywhere.
Attachment #8817707 - Flags: review?(gbrown)
Convert JavascriptBridge, JavascriptTest, and other relevant code to use
the new Bundle events. We used the same "Robocop:JS" event for
communicating both ways before, but now that we have a unified bus, we
need two different events, "Robocop:JS" and "Robocop:Java" for two-way
communication.
Attachment #8817709 - Flags: review?(gbrown)
Attachment #8817707 - Flags: review?(gbrown) → review+
Attachment #8817709 - Flags: review?(gbrown) → review+
:jchen -- you mentioned some concerns about robocop timeouts; was that related to try runs for this bug, or ...?
(In reply to Geoff Brown [:gbrown] from comment #4)
> :jchen -- you mentioned some concerns about robocop timeouts; was that
> related to try runs for this bug, or ...?

I actually figured that out. My changes were causing each test to run a little longer than usual, and together, all tests ended up taking longer than the 1 hr limit for the taskcluster job, and so were getting killed, although the taskcluster output wasn't very helpful. I was able to find the cause and fix it.
Attachment #8817706 - Flags: review?(snorp) → review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d18a1e82b1f9
1. Convert property name to string if necessary; r=snorp
https://hg.mozilla.org/integration/mozilla-inbound/rev/56a083633c9b
2. Convert test-only events to Bundle events; r=gbrown
https://hg.mozilla.org/integration/mozilla-inbound/rev/98a33f1e748e
3. Convert JavascriptBridge to use Bundle events; r=gbrown
https://hg.mozilla.org/mozilla-central/rev/d18a1e82b1f9
https://hg.mozilla.org/mozilla-central/rev/56a083633c9b
https://hg.mozilla.org/mozilla-central/rev/98a33f1e748e
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Product: Firefox for Android → GeckoView
Target Milestone: Firefox 53 → mozilla53
You need to log in before you can comment on or make changes to this bug.