Closed Bug 1322720 Opened 3 years ago Closed 3 years ago

Don't show either about:home or about:newtab on first run for the feb 2017 funnelcake

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 53
Tracking Status
firefox51 --- verified
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: pref: browser.startup.firstrunSkipsHomepage = true)

Attachments

(1 file)

This too should be behind a pref so we can keep the normal behaviour for release and the 'baseline' funnelcake
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8818916 [details]
Bug 1322720 - don't show the homepage on firstrun if a pref is flipped,

https://reviewboard.mozilla.org/r/98848/#review99112

::: browser/app/profile/firefox.js:220
(Diff revision 1)
>  // 0 = blank, 1 = home (browser.startup.homepage), 2 = last visited page, 3 = resume previous browser session
>  // The behavior of option 3 is detailed at: http://wiki.mozilla.org/Session_Restore
>  pref("browser.startup.page",                1);
>  pref("browser.startup.homepage",            "chrome://branding/locale/browserconfig.properties");
> +// If we should not show the homepage on firstrun
> +pref("browser.startup.firstrun_ignorehomepage", false);

I'd prefer:

// Whether we should skip the homepage when opening the first-run page
pref("browser.startup.firstrunSkipsHomepage", false);

::: browser/components/nsBrowserContentHandler.js:554
(Diff revision 1)
>      }
>  
>      if (startPage == "about:blank")
>        startPage = "";
>  
> -    // Only show the startPage if we're not restoring an update session.
> +    let ignoreStartPage = override == OVERRIDE_NEW_PROFILE &&

nit: s/ignoreStartPage/skipStartPage/
Attachment #8818916 - Flags: review?(dao+bmo) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f769dad8caea
don't show the homepage on firstrun if a pref is flipped, r=dao
https://hg.mozilla.org/mozilla-central/rev/f769dad8caea
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Is this ready for uplift?
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Dão Gottwald [:dao] from comment #6)
> Is this ready for uplift?

Waiting to hear from Dolske, going to clear ni for now.
Flags: needinfo?(gijskruitbosch+bugs)
Whiteboard: pref: browser.startup.firstrunSkipsHomepage = true
Comment on attachment 8818916 [details]
Bug 1322720 - don't show the homepage on firstrun if a pref is flipped,

Approval Request Comment
[Feature/Bug causing the regression]: bug 1322718 comment #1
[User impact if declined]: can't run the funnelcake
[Is this code covered by automated tests?]: No, this is specifically about first-run, which we can't automatically test it.
[Has the fix been verified in Nightly?]: no, as it needs a custom build with a pref flipped. All this code is behind a pref.
[Needs manual test from QE? If yes, steps to reproduce]: Yes. We'll need a custom build set up. With the custom build, the only check required is that on a fresh profile, only the initial welcome page should show up on the first run of Firefox (and not about:home or a second tab with about:newtab).
[List of other uplifts needed for the feature/fix]: this is related to all the other deps of bug 1322718, but the patch is standalone and can be uplifted independently.
[Is the change risky?]: no
[Why is the change risky/not risky?]: because it will only affect the funnelcake (ie it's behind a pref)
[String changes made/needed]: no.
Attachment #8818916 - Flags: approval-mozilla-beta?
Attachment #8818916 - Flags: approval-mozilla-aurora?
Comment on attachment 8818916 [details]
Bug 1322720 - don't show the homepage on firstrun if a pref is flipped,

For onboarding funnelcake as discussed with dolske. OK for aurora + beta.
Attachment #8818916 - Flags: approval-mozilla-beta?
Attachment #8818916 - Flags: approval-mozilla-beta+
Attachment #8818916 - Flags: approval-mozilla-aurora?
Attachment #8818916 - Flags: approval-mozilla-aurora+
[bugday-20170105] Bug verified
(In reply to Rajesh from comment #12)
> [bugday-20170105] Bug verified

How? You need a substantial number of preferences flipped, some at first startup in a profile, which is very hard to configure without recompiling Firefox. What did you check?
Flags: needinfo?(rockzoft23)
Setting the flag for verification, instructions available in Comment 8.
Flags: qe-verify+
Flags: needinfo?(gwimberly)
Per Comment 8: On the first run of Funnelcake: If it is not about:home or about:newtab, is there a specific URL on the welcome page that is shown?
Flags: needinfo?(gwimberly) → needinfo?(gijskruitbosch+bugs)
(In reply to Grover Wimberly IV [:Grover-QA] from comment #15)
> Per Comment 8: On the first run of Funnelcake: If it is not about:home or
> about:newtab, is there a specific URL on the welcome page that is shown?

With the distribution.ini, I think it should be something like https://www.mozilla.org/en-US/firefox/51.0/firstrun/?f=99 , when this is the only (and a new) profile that starts up the first time.
Flags: needinfo?(gijskruitbosch+bugs)
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(rockzoft23)
You need to log in before you can comment on or make changes to this bug.