Closed Bug 13228 Opened 20 years ago Closed 20 years ago

[FEATURE] Yes/No/Never dialog needed

Categories

(SeaMonkey :: UI Design, defect, P1)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: morse, Assigned: don)

References

Details

(Whiteboard: Need to find an owner for this)

Need a dialog that contains message text and three buttons.  The buttons are to
be labelled "Yes", "No", and "Never for this site".  This is described in item 2
of bug 13022.
Blocks: 13022
The API that I would like to see for this dialog is:

NS_IMETHOD PromptDoublePassword
  (const PRUnichar *text,
   const PRUnichar *text2,
   PRUnichar **pwd,
   PRUnichar **pwd2,
   PRBool *_retval)
Blocks: 7530
Component: HTML Dialogs → XPApps
Priority: P3 → P1
Summary: [Blocking] Yes/No/Never dialog needed → [FEATURE] Yes/No/Never dialog needed
Target Milestone: M14
Let's do this after beta.
*** Bug 18534 has been marked as a duplicate of this bug. ***
*** Bug 19087 has been marked as a duplicate of this bug. ***
*** Bug 19935 has been marked as a duplicate of this bug. ***
why not just go like this, as suggested with bug 19935?
It makes more sense...

+------------------------------------------------+
|[] Authentication required :::::::::::::::::::::|
+------------------------------------------------+
| Enter user name and password for {blah}        |
| at {server-name}:                              |
|            __________________________________  |
| User name [__________________________________] |
| Password  [__________________________________] |
|            _                                   |
|           [_] Remember username and password   |
|                                                |
|                          ( Cancel ) ((  Ok  )) |
+------------------------------------------------+
*** Bug 21795 has been marked as a duplicate of this bug. ***
Assignee: davidm → don
Whiteboard: Need to find an owner for this
Target Milestone: M14 → M15
After beta 1 ...
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I implemented a universal dialog from which I can custom-build various dialogs.
The Yes,No,Never dialog requested here is a special case of the universal
dialog.  It's now checked in and working.  Marking bug as fixed.
QA Contact: cpratt → sairuh
Reassigning QA Contact.
QA Contact: sairuh → elig
the only time i've seen this dialog is when being asked to save a
username/passwd signon --where are there other places where this shows up?

handing this over to eli for verif, since dialogs are his realm...
That's the only place its used.
Verified that following the steps to reproduce in bug #18534 yields a "Yes, "No", 
"Never for this site" dialog, using the 2.07.00 AM builds on Win32, Mac OS & 
Linux.

If there's more to verifying this bug than that, please say so.

Thanks!
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.