If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Aggregate on Addons is confusing, as version numbers and names are mixed

RESOLVED DUPLICATE of bug 1250132

Status

Socorro
General
RESOLVED DUPLICATE of bug 1250132
10 months ago
7 months ago

People

(Reporter: YF (Yang), Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
STR:
1. Open like https://crash-stats.mozilla.com/signature/?product=Firefox&signature=mozilla%3A%3Anet%3A%3ADataChannelParent%3A%3AOnDataAvailable&date=%3E%3D2016-11-01T05%3A31%3A00.000Z&date=%3C2016-12-10T05%3A31%3A00.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_sort=-date&page=1#aggregations 
2. Set "Aggregate on..." to "addons".
3. Check this Addons section, some Addons shows as version numbers instead of name or UUID (It should be), they are unrecognized.
(Reporter)

Comment 1

8 months ago
Can you help triaging this bug?
Flags: needinfo?(mcastelluccio)
Version: unspecified → Trunk
The problem stems from the fact that "addons" is an array of strings with the format: [ADDON_1_NAME, ADDON_1_VERSION, ADDON_2_NAME, ADDON_2_VERSION, ..., ADDON_N_NAME, ADDON_N_VERSION]. Once you know this, you can interpret the results (so there are no addons that are displayed as version numbers instead of names).

I don't know how hard it is to make this easier to interpret, probably Adrian knows.
Flags: needinfo?(mcastelluccio) → needinfo?(adrian)
Summary: Aggregate on Addons displays some items as version number instead of name → Aggregate on Addons is confusing, as version numbers and names are mixed
This is already known and filed as bug 1250132. Please comment there to make it move up in priority! :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Flags: needinfo?(adrian)
Resolution: --- → DUPLICATE
Duplicate of bug: 1250132
You need to log in before you can comment on or make changes to this bug.