[RFE] append constant key/value pair to Internet Keywords search query

RESOLVED INVALID

Status

--
enhancement
RESOLVED INVALID
17 years ago
10 years ago

People

(Reporter: bill+mozilla-bugzilla, Assigned: samir_bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

When Mozilla does an Internet Keywords search, it should append a known suffix
to the URL, e.g. '&mozilla-ik=true'.

As someone writing a search engine or a dedicated Internet Keywords server, you
can know that the user is sending an IK search and do the appropriate thing
(probably sending a 302).

This would allow the Default Search Engine to be used deterministically for URL
searches (bug 53171) and would clear up the confusion between Internet Keywords
searches and regular searches (bug 76547).

Someone at Netscape would just have to add a couple lines to their search
product to handle it (yes I'm making assumptions about how it's written) and
everyone would be able to be an IK provider, democratizing that landscape.

Comment 1

17 years ago
setting status to New
Status: UNCONFIRMED → NEW
Ever confirmed: true
I seem to have filed this bug in a fit of stupidity.  Bug 137026 is a less
stupid bug that addresses the problem more modularly.  I would have closed this
one as INVALID if I had realized I hadn't closed it before.

Asa, thanks for NEW'ing it, and I'm sorry to have wasted your effort, but if you
don't object I'd be happier closing this one.
Marking invalid since it's not really a good idea.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.