If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Interaction between updater and e10s child process recovery causes zombie processes

RESOLVED DUPLICATE of bug 1112937

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1112937
9 months ago
3 months ago

People

(Reporter: The 8472, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
Created attachment 8817821 [details]
zombie processes.png

I'm using multiple profiles for development (via firefox.exe -P -no-remote) and e10s is on too. I'm not sure about the exact sequence of events, but it seems like closing one of the profiles may have prepared some updates to a new .exe and then when a child process crashed in another still running profile and it tried to spawn a new child process something went wrong and a dozen zombie processes gor started. Even closing that profile did not close the processes and I cannot kill them either, they're stuck in suspended state.

Comment 1

9 months ago
Bill or Rob, any idea what we can do about this? Feels like the updater shouldn't update firefox while other instances are still running, or something... but I don't know how easy it is to fix that. :-\
Flags: needinfo?(wmccloskey)
Flags: needinfo?(robert.strong.bugs)

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(wmccloskey)
Resolution: --- → DUPLICATE
Duplicate of bug: 1112937
Flags: needinfo?(robert.strong.bugs)
You need to log in before you can comment on or make changes to this bug.