All users were logged out of Bugzilla on October 13th, 2018

Preview images, streaming content, etc. in Download Manager

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
17 years ago
9 years ago

People

(Reporter: xyzzy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Similar to the existing Launch capability, this request is for the ability to
view images (esp. progressive or interlaced formats) and streaming content
(audio, video, etc.) via the Download Manager while the transfer is in progress.

It would be nice to support 3rd party players, but using the existing internal
handlers (images, sound, etc.) would be a great start.

Updated

17 years ago
Summary: [RFE] Preview images, streaming content, etc. in Dowload Manager → [RFE] Preview images, streaming content, etc. in Download Manager
QA Contact: sairuh → petersen
Summary: [RFE] Preview images, streaming content, etc. in Download Manager → Preview images, streaming content, etc. in Download Manager
*** Bug 260863 has been marked as a duplicate of this bug. ***
Or simply to be able to have mozilla copy the temporary file to another location
and show the open dialog for it. This could be done with a "preview" link under
"open" in download manager, which would copy the file to the desktop with a name
like file.tmp.ext


I thought of this when I was downloading an .avi and wanted to preview it by
fixing it with DIVFIX, then viewing it... The download was 4 hours, and if I
cancelled or paused the download, I couldn't get at the file without searching
for the temp.

Perhaps streaming should be turned into another bug, since that's more involved
and might make this bug turn into too much of a discussion.
>I couldn't get at the file without searching
>for the temp.

that would be in the target directory, with the selected name, with appended .part
The target directory was the desktop. There was no .part there. I found the file
in C:\Documents and settings\...\temp
Product: Browser → Seamonkey
Assignee: bross2 → download-manager
QA Contact: chrispetersen

Comment 5

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 6

9 years ago
We have no plans for implementing this in core SeaMonkey code, but this can be tried as an add-on for sure :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.