Closed Bug 13229 Opened 21 years ago Closed 21 years ago

NGLayout falls apart with CSS background images and transparent gifs

Categories

(Core :: Layout, defect, P3)

All
Other
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: jrankine, Assigned: troy)

References

()

Details

(Whiteboard: [TESTCASE])

Attachments

(1 file)

On my site I use CSS to have nice watermark backgrounds.  I also use transparent GIF's so that these backgrounds can show through product shots.  Mozilla will incorrectly render the transparent GIF's as blank with some other random layout aspects in the image area.
Thinks look fine on 1999-09-05-08-M11 Linux viewer on the page
http://www.devtel.com/ (which has backgrounds that you describe).  What build
are you using?
Note that the bug isn't apparent until you resize or scroll the page. ;)
Reporter responded by email:
> I am using Win32 Build 9-6-99, but I encountered the problem before this.
> The bug isn't apparent until you MOVE the page in anyway, e.g. scrolling
> etc.

Well, it looks OK on Linux, but maybe someone will see it on Windows.
Whiteboard: [TESTCASE]
The <IMG> which is replaced when the links are hovered has
width=100 and height=100, this means that the images must be scaled to fit.
This has several problems in Mozilla:

  1.It seems to be really, really slow compared to Communicator 4.61 or IE4.
  2.It doesn't seem to cache previously incomplete calulations. (If I leave
    the link before the image is downloaded and scaled it starts from scratch
    next time I hover the link.)
  3.Sometimes it just gives up and never completes the download and/or scaling.
    (I hovered a link for 10 minutes and the image didn't pop up.)

Before the image is downloaded and scaled the area is "erased" (painted with
white color) and the ALT text is displayed. I think that the problem the
reporter is experiencing is the combined effect of this "erasing" and the
problems mentioned above.
(I was using apprunner 1999-09-05-12-M10 on Windows NT4sp5.)
The attachment 09 [details]/07/99 13:29 shows the problems with the mouseOver images, but
the problem exists also with just plain static transparent GIF's overtop of a
CSS background image.
Hmm, I didn't see any transparency problem (other than the "erasing" problem
occuring before the image is downloaded/scaled as described above). Which
image at http://www.devtel.com are you referring to ?
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Your test case looks fine to me as well, on NT anyway.
Status: RESOLVED → VERIFIED
With the Sept 16th build, I can't reproduce the problem described. Works
correctly on Mac 8.6, Window 95, Windows 98, Redhat 6.0.
You need to log in before you can comment on or make changes to this bug.