RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
a year ago
a year ago

People

(Reporter: Kathryn Pew, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161129173726

Steps to reproduce:

I tried to use my university's library site to access a journal.  It uses the following to take me to the EBSCO host site.

The new release of Firefox makes it impossible for me to use the proxy that the library at my university uses to access the EBSCO site.   I keep getting a message that there is something wrong with the certificate.  Here is the URL https://libproxy.library.unt.edu:2048/login?url=http://search.ebscohost.com/direct.asp?db=lls&jid=R5A&scope=site


Actual results:

Browser refused to load the page, saying there was something wrong with the certificate.  I tried to create an exception, but the new dialog did not like the URL above.  It tells me that there is nothing wrong with the https://libproxy.library.unt.edu certificate.  So I am kind of stuck.

Here is the message displayed to me:
The connection to libproxy.library.unt.edu:2048 was interrupted while the page was loading.

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.


Expected results:

Browser should have loaded the page and/or given me some option.

Comment 1

a year ago
It does not work on Fx4.0 & 28.0 & 51.0b6 & Nightly 53.0a1 (2016-12-10) & MS Edge, and Chrome say "ERR_SSL_PROTOCOL_ERROR". This looks to be a issue of the site.

>curl -v https://libproxy.library.unt.edu:2048/
* timeout on name lookup is not supported
*   Trying 129.120.93.218...
* TCP_NODELAY set
* Connected to libproxy.library.unt.edu (129.120.93.218) port 2048 (#0)
* schannel: SSL/TLS connection with libproxy.library.unt.edu port 2048 (step 1/3)
* schannel: checking server certificate revocation
* schannel: sending initial handshake data: sending 205 bytes...
* schannel: sent initial handshake data: sent 205 bytes
* schannel: SSL/TLS connection with libproxy.library.unt.edu port 2048 (step 2/3)
* schannel: failed to receive handshake, need more data
* schannel: SSL/TLS connection with libproxy.library.unt.edu port 2048 (step 2/3)
* schannel: encrypted data buffer: offset 26 length 4096
* schannel: next InitializeSecurityContext failed: SEC_E_INVALID_TOKEN (0x80090308) - 给函数提供的标志无效
* Curl_http_done: called premature == 1
* Closing connection 0
* schannel: shutting down SSL/TLS connection with libproxy.library.unt.edu port 2048
* schannel: clear security context handle
curl: (35) schannel: next InitializeSecurityContext failed: SEC_E_INVALID_TOKEN (0x80090308) -
Summary: certificate → Unable connect to https://libproxy.library.unt.edu:2048
I tested this and I can confirm what YF said in comment 1. I have the same results on all the browsers that I used: Firefox Nighlty 53, FF 50 release, FF 49, FF 48, Safari and Chrome. I think is a site issue not a browser one.
Hi,
Marking this as Resolved: Incomplete due to the lack of response from the reporter.
If the issue is still reproducible with the latest Firefox version, feel free to reopen the bug with more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.