Need to put location of MOZILLA_HOME in OS2.INI

VERIFIED FIXED

Status

()

Core
XPCOM
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: mkaply, Assigned: mkaply)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

16 years ago
On OS/2, unlike other platforms, the user profiles can be located in 
different places.

The boot drive can be FAT, so we can't just put the user profiles in a 
given location.

Because of this, we need a wayto specify the location of the user 
profiles in such a way that third party applications can find them and 
modify them.

This fix adds a call to set the current location of MOZILLA_HOME into 
OS2.INI, whether it is using the MOZILLA_HOME environment variable or 
the location of the executable.
(Assignee)

Comment 1

16 years ago
Created attachment 75176 [details] [diff] [review]
Put path in OS2.INI every time we start.

Updated

16 years ago
Attachment #75176 - Flags: review+

Comment 2

16 years ago
Comment on attachment 75176 [details] [diff] [review]
Put path in OS2.INI every time we start.

r=dougt, although I claim no os2 knowledge.

Comment 3

16 years ago
back to mike.  Mike, do you care to drive this in?
Assignee: dougt → mkaply

Comment 4

16 years ago
Comment on attachment 75176 [details] [diff] [review]
Put path in OS2.INI every time we start.

sr=scc (but please, in future, remember to diff -u :-)
Attachment #75176 - Flags: superreview+
(Assignee)

Comment 5

16 years ago
Created attachment 75638 [details] [diff] [review]
diff -u of same patch

This is the same patch with a -u

Comment 6

16 years ago
Comment on attachment 75638 [details] [diff] [review]
diff -u of same patch

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #75638 - Flags: approval+
(Assignee)

Comment 7

16 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

16 years ago
*** Bug 129718 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

16 years ago
Verify - this is fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.