Closed Bug 1323012 Opened 6 years ago Closed 6 years ago

Recording video with playbackRate = 0.5 should generate video with double duration (using mozCaptureStream())

Categories

(Core :: Audio/Video: Recording, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1517199
Tracking Status
firefox53 --- affected

People

(Reporter: sole, Unassigned)

References

()

Details

When you try to record the output of a video which uses playbackRate != 1, using mozCaptureStream (in lieu of having the non prefixed version implemented), you expect the captured video to reflect the actual rate that was used to play the media.

For example this test cases plays a video with playbackRate = 0.5 which if captured should generate a stream that lasts double. Since the original video is 9 seconds long, the captured (via MediaRecorder) video should be 18 seconds. But it is reported to be 8.999 seconds, which is even less!

(Thanks to Joshua for finding this bug - his original gist is here https://twitter.com/BlurSpline/status/808332434940903425 :-))
Thanks Sole, duping accordingly (this is caused by a higher level issue), as we're tracking this together with `volume` not working as well.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 966247
You need to log in before you can comment on or make changes to this bug.