Inputting devangari script in firefox is buggy in recent versions

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
10 months ago
10 months ago

People

(Reporter: firefox_luver, Unassigned)

Tracking

50 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 months ago
Created attachment 8818051 [details]
devanagari-input.mp4

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161129173726

Steps to reproduce:

I opened a support request with apple for this issue but they think it is either a browser or google docs issue. After some thought, I suspect that a recent change in firefox may have broken how unicode input is displayed. 

I'm using firefox 50.0.2 on OSX 10.12.1. Below is transcript of the report that I submitted to apple.


To type a consonant in devangari (e.g. क्) with the Devanagari QWERTY keyboard, I normally type kf. Now, I'm forced to hit an additional space after "f" to move the cursor forward. Similarly, if I want to type a conjunct consonant, say क्र, I type kfr. However, to produce this, I am not required to type kfrr

Steps to Reproduce:
Change input font to Devanagari QWERTY
Type kfr and notice that it doesn't output क्र
Type kfrr and notice that it outputs क्र

I'm attaching a screen-capture of the whole process as an mp4 video. 





Actual results:

Without the extra r, the desired conjunct consonant क्र does not get printed.


Expected results:

Typing the second r in kfrr should not be necessary.
(Reporter)

Updated

10 months ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

10 months ago
Created attachment 8818122 [details]
Performed testing with older releases of mozilla

The bug doesn't exist in releases 48.0.1 and 49 but does exist in 50.0.1. Please play the attached video to view my testing.

Comment 2

10 months ago
It's probably a dupe of bug 1320499 which is a dupe of bug 1303273 which is fixed in 52+.
You can test yourself if you want, just download the DE version:
https://www.mozilla.org/en-US/firefox/developer/all/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1303273
No, bug 1303273 is Windows specific bug. Looks like this is a bug on macOS. Although, I've landed a lot of fixes into macOS too.

firefox_luver:

Could you check if this bug is fixed in Beta, Developers Edition and Nightly?
https://www.mozilla.org/en-US/firefox/channel/desktop/
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

10 months ago
Hi Masayuki,

I tried a developer version 52.0a2 (2016-12-13) (64-bit) on my mac and it indeed fixes the problem.

Thanks

Comment 5

10 months ago
Based on comment 4 from firefox_luver(reporter) I will mark this as resolved WFM.
Status: REOPENED → RESOLVED
Last Resolved: 10 months ago10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.