Resize problems on Page Info / Media with large image

VERIFIED DUPLICATE of bug 122055

Status

SeaMonkey
Page Info
VERIFIED DUPLICATE of bug 122055
16 years ago
13 years ago

People

(Reporter: Malcolm Scott, Assigned: db48x)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2002031008

The Media tab of the Page Info dialog has problems if the image is larger than
the space available. You see the info panel at the top moving up and down by ~20
pixels very rapidly, apparently as the dialog tries to fit the image in without
obliterating dialog elements.

Reproducible: Always
Steps to Reproduce:
1. Go to a page with a large image, e.g. http://www.thelinuxreview.com/TUX/01/
2. Right-click page & choose 'View Page Info'
3. Go to the Media tab
4. If the image fits in the space available, shrink the dialog box vertically
until you see something happen.

Actual Results:  The dialog box goes crazy and vibrates all over the place.
Also, notice that if you resize the dialog, the contents don't resize with the
window frame (probably because it's too busy redrawing).

Expected Results:  The dialog box should come to some sort of arrangement with
large images, e.g. scrollbars.

NB1: The behaviour above happens on Linux. On Windows, the dialog is partially
drawn then freezes. (Presumably Windows can't redraw fast enough to see the
vibrate effect you get on Linux.)

NB2: The "Media" tab in the "Page Info" dialog appears to have been added for
0.9.9 . In 0.9.8, the tab was called "Images", and did not show this problem:
the image was drawn with scrollbars.
Should be fixed since 2002-03-15

*** This bug has been marked as a duplicate of 122055 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.