Closed Bug 1323048 Opened 5 years ago Closed 5 years ago

Update Puppeteer libraries and tests to use get_property where appropriate

Categories

(Testing :: Firefox UI Tests, defect)

Version 3
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1277090

People

(Reporter: whimboo, Unassigned)

References

Details

(Keywords: pi-marionette-firefox-puppeteer)

Once bug 1277090 has been fixed and a new release of marionette_client is out (bug 1320073), we should check all instances of get_attribute() if they can be changed to get_property().
The fix for bug 1277090 was not part of the latest marionette-driver release. So this is still blocked.
No longer depends on: 1320073
We figured out that we cannot do that after the patch on bug 1277090 has been landed, but it has to be done at the same time.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1277090
You need to log in before you can comment on or make changes to this bug.