Closed Bug 1323049 Opened 4 years ago Closed 4 years ago

Window is painted incorrectly on Windows

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: rhunt, Unassigned)

References

Details

Attachments

(1 file)

Attached image Capture.PNG
With WR enabled the window is painted incorrectly. It looks like everything is offset by the title bar height, and then nothing gets painted there.

Input still works normal so if you hover over where the close button should be, it gets highlighted, but still offset incorrectly.
I confirmed the problem on my Win 10 laptop, but failed to reproduce on my Win10 desktop PC.
(In reply to Sotaro Ikeda [:sotaro] from comment #1)
> I confirmed the problem on my Win 10 laptop, but failed to reproduce on my
> Win10 desktop PC.

The following might be related to the problem.

The Win10 pc that does not have a problem uses nvidia's driver. The Win10 laptop that cause the problem uses intel's driver.
When the problem happened, webrender(OpenGL) did not render to white area. The white area is mostly non-client are of the app. The content area is extended to non-client area by handling WM_NCCALCSIZE message by https://dxr.mozilla.org/mozilla-central/source/widget/windows/nsWindow.cpp#5012.

When the problem happened, it seemed that the WM_NCCALCSIZE message handling did not extend the content area. Then it might be a platform for intel driver's problem.

I forcibly enabled OpenGL composition on the Win10 laptop, then I saw the same incorrect painting.
I did not see this bug's problem when OpenGLES via ANGLE is used on grahics branch.
(In reply to Sotaro Ikeda [:sotaro] from comment #4)
> I did not see this bug's problem when OpenGLES via ANGLE is used on grahics
> branch.

Though OpenGLES via ANGLE has another problem for now.
(In reply to Sotaro Ikeda [:sotaro] from comment #3)
>
> I forcibly enabled OpenGL composition on the Win10 laptop, then I saw the
> same incorrect painting.

Correction:
I forcibly enabled OpenGL composition on m-c & the Win10 laptop, then I saw the same incorrect painting.
(In reply to Sotaro Ikeda [:sotaro] from comment #3)
> 
> When the problem happened, it seemed that the WM_NCCALCSIZE message handling
> did not extend the content area. Then it might be a platform for intel
> driver's problem.

Correction:
Then it might be a problem of windows or intel  driver.
I have not noticed this since bug 1323316 landed. Is this still a problem or can this be closed?
Flags: needinfo?(sotaro.ikeda.g)
Yes, this could be closed. thanks:)
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(sotaro.ikeda.g)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.