Turning off 'cookie support' in javascript doesn't work

VERIFIED WORKSFORME

Status

()

Core
Networking: Cookies
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: ned wolpert, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using 0.9.9 (Linux 7.2, redhat) I went into preferences and turned off cookie
support (read, create and modify) in javascript, and turned on notify when new
cookies were being set.  I went to 'www.fuckedcompany.com' and then selected 
the image on the right-hand side to turn 'off' model pics.  The resulting page
has a javascript call that sets a new cookie.  Note that I use junkbusters, 
which blocks cookie requests in the HTTP header, so I know that nothing was
sent in the header.  (I turned on jarfile in junkbusters so any cookies being
sent are stored there, which I reviewed had none from www.fuckedcompany.com)

Comment 1

16 years ago
Browser, not engine ---> Cookies for further triage
Assignee: rogerl → morse
Component: JavaScript Engine → Cookies
QA Contact: pschwartau → tever
You need to restart to get the prefs in "Scripts & Windows" to take effect in
0.9.9...

Comment 3

16 years ago
REPORTER: Can you check if the problem persists with a more recent build, and if
it occurs after a restart as bz suggested. Please report back to this bug so
that we can keep a good track of problems. Thanks for helping with mozilla.
wfm, as nobody can reproduce it. reopen if you canusing a recent build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 5

15 years ago
VERIFIED: WFM.

You don't have to reboot anymore.
Mozilla 1.4b, Win 98.
Status: RESOLVED → VERIFIED
QA Contact: tever → cookieqa

Updated

13 years ago
QA Contact: core.networking.cookies → benc
You need to log in before you can comment on or make changes to this bug.