./mach marionette-test is broken since bug 1320073 landed

RESOLVED FIXED in Firefox 52

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ato, Assigned: ato)

Tracking

({regression})

Version 3
mozilla53
regression
Points:
---

Firefox Tracking Flags

(firefox52 fixed, firefox53 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
`./mach marionette-test` is broken:

% ./mach marionette-test testing/marionette/harness/marionette_harness/tests/unit/test_execute_script.py --gecko-log -
Error running mach:

    ['marionette-test', 'testing/marionette/harness/marionette_harness/tests/unit/test_execute_script.py', '--gecko-log', '-']

The error occurred in mach itself. This is likely a bug in mach itself or a
fundamental problem with a loaded module.

Please consider filing a bug against mach by going to the URL:

    https://bugzilla.mozilla.org/enter_bug.cgi?product=Core&component=mach


If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

ImportError: No module named marionette.runtests

  File "/home/ato/src/gecko/python/mach/mach/main.py", line 352, in run
    return self._run(argv)
  File "/home/ato/src/gecko/python/mach/mach/main.py", line 407, in _run
    args = parser.parse_args(argv)
  File "/usr/lib/python2.7/argparse.py", line 1701, in parse_args
    args, argv = self.parse_known_args(args, namespace)
  File "/usr/lib/python2.7/argparse.py", line 1733, in parse_known_args
    namespace, args = self._parse_known_args(args, namespace)
  File "/usr/lib/python2.7/argparse.py", line 1921, in _parse_known_args
    positionals_end_index = consume_positionals(start_index)
  File "/usr/lib/python2.7/argparse.py", line 1898, in consume_positionals
    take_action(action, args)
  File "/usr/lib/python2.7/argparse.py", line 1807, in take_action
    action(self, namespace, argument_values, option_string)
  File "/home/ato/src/gecko/python/mach/mach/dispatcher.py", line 173, in __call__
    if handler.parser:
  File "/home/ato/src/gecko/python/mach/mach/decorators.py", line 77, in parser
    self._parser = self._parser()
  File "/home/ato/src/gecko/testing/marionette/mach_commands.py", line 27, in setup_marionette_argument_parser
    from marionette.runtests import MarionetteArguments
  File "/home/ato/src/gecko/build/mach_bootstrap.py", line 370, in __call__
module = self._original_import(name, globals, locals, fromlist, level)
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Assignee: nobody → ato
Status: NEW → ASSIGNED

Comment 2

2 years ago
mozreview-review
Comment on attachment 8818305 [details]
Bug 1323217 - Fix mach marionette-test;

https://reviewboard.mozilla.org/r/98422/#review98626
Attachment #8818305 - Flags: review?(hskupin) → review+

Comment 3

2 years ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/489f981e8c2b
Fix mach marionette-test. r=whimboo a=test-only
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Regression from bug 1320073. We will have to get this uplifted to aurora too once the patch on the other bug gets uplifted.

Thanks for fixing it.
Blocks: 1320073
status-firefox52: --- → affected
status-firefox53: --- → fixed
Keywords: regression
Target Milestone: --- → mozilla53
Summary: ./mach marionette-test is broken → ./mach marionette-test is broken since bug 1320073 landed
Test-only patch which we need on aurora. Please uplift the patch on bug 1320073 first within the same merge because this patch fixes a regression. Thanks.
Whiteboard: [checkin-needed-aurora][uplift patch on bug 1320073 first]
Some deps haven't been landed on aurora yet and cause merge bustage. I will request those uplifts first.
Whiteboard: [checkin-needed-aurora][uplift patch on bug 1320073 first] → [uplift patch on bug 1320073 first]
Whiteboard: [uplift patch on bug 1320073 first] → [checkin-needed-aurora][uplift patch on bug 1320073 first]

Comment 7

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/b557465f8078
status-firefox52: affected → fixed

Updated

2 years ago
Whiteboard: [checkin-needed-aurora][uplift patch on bug 1320073 first]
You need to log in before you can comment on or make changes to this bug.