Closed Bug 1323221 Opened 3 years ago Closed 3 years ago

Colors appear to be swapped/incorrect on websites when viewing Firefox using xRDP/VNC.

Categories

(Firefox :: Untriaged, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1319554

People

(Reporter: triforce66, Unassigned)

Details

Attachments

(1 file)

777.62 KB, application/zip
Details
Attached file Screenshots.zip
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161129173726

Steps to reproduce:

Setup default Ubuntu/Lubuntu/Xubuntu machine.
Update all packages (sudo apt-get update and sudo apt-get upgrade)
Login locally and open Firefox and goto an image heavy website like https://www.reddit.com
	- Colors will appear correct - See attachment Screenshot_Correct_Colors_Firefox.png
Install/Configure xRDP (instructions noted here, http://www.tweaking4all.com/software/linux-software/use-xrdp-remote-access-ubuntu-14-04/
RDP into Lubuntu/Xubuntu machine and open Firefox and goto an image heavy website like https://www.reddit.com again. 
	- Colors will appear incorrect/swapped/blue tint - See attachment Screenshot_Incorrect_Colors_Firefox.png

Please let me know if there are any additional troubleshooting steps you would like me to perform to assist. 


Actual results:

Colors will appear incorrect/swapped/blue tint - See attachment 
Screenshot_Incorrect_Colors_Firefox.png
Colors appear to be swapped on websites when viewing desktop using xRDP/VNC. Issue seem to start around Firefox 50 release. Tested on fresh Lubuntu 16.04.1 and Xubuntu 16.04.1 installs. 



Expected results:

Colors will appear correct - See attachment Screenshot_Correct_Colors_Firefox.png
Issue appears to only be related to Firefox as no other applications appear to have this issue. I also confirmed Chrome displays website colors correctly too.
It's fixed in 51.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1319554
You need to log in before you can comment on or make changes to this bug.