Crash in java.lang.IllegalStateException: Expected session to be started before session end is called at org.mozilla.gecko.telemetry.TelemetryCorePingDelegate.onPause(TelemetryCorePingDelegate.java)

RESOLVED DUPLICATE of bug 1317191

Status

()

Firefox for Android
Metrics
--
critical
RESOLVED DUPLICATE of bug 1317191
10 months ago
10 months ago

People

(Reporter: kbrosnan, Unassigned)

Tracking

({crash})

unspecified
Unspecified
Android
crash
Points:
---

Firefox Tracking Flags

(firefox50 affected, firefox51 affected)

Details

(crash signature)

(Reporter)

Description

10 months ago
This bug was filed from the Socorro interface and is 
report bp-648590b0-ac7f-4f9a-bbcd-380262161213.
=============================================================

New in Firefox for Android 50.

java.lang.IllegalStateException: Expected session to be started before session end is called
	at org.mozilla.gecko.telemetry.TelemetryCorePingDelegate.onPause(TelemetryCorePingDelegate.java:95)
	at org.mozilla.gecko.BrowserApp.onPause(BrowserApp.java:1125)
	at android.app.Activity.performPause(Activity.java:6447)
	at android.app.Instrumentation.callActivityOnPause(Instrumentation.java:1308)
	at android.app.ActivityThread.performPauseActivity(ActivityThread.java:3731)
	at android.app.ActivityThread.performPauseActivity(ActivityThread.java:3704)
	at android.app.ActivityThread.handlePauseActivity(ActivityThread.java:3679)
	at android.app.ActivityThread.access$1100(ActivityThread.java:177)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1460)
	at android.os.Handler.dispatchMessage(Handler.java:102)
	at android.os.Looper.loop(Looper.java:145)
	at android.app.ActivityThread.main(ActivityThread.java:5951)
	at java.lang.reflect.Method.invoke(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:372)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1400)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1195)



Mfg      Model      And Ver      ABI       #   
samsung  GT-I9505  21 (REL)  armeabi-v7a  20  15.3%
samsung  SM-G935F  23 (REL)  armeabi-v7a   9   6.9%
samsung  SM-G920F  23 (REL)  armeabi-v7a   7   5.3%
samsung  SM-G930F  23 (REL)  armeabi-v7a   7   5.3%
samsung  GT-I9506  21 (REL)  armeabi-v7a   5   3.8%
Track 51+ as crash in 51.

Hi :sebastian,
Can you help shed some light here?
tracking-firefox51: ? → +
Flags: needinfo?(s.kaspari)
This is a duplicate of bug 1317191. There is already a discussion going on in the other bug, so I'll close this one here.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(s.kaspari)
Resolution: --- → DUPLICATE
Duplicate of bug: 1317191
moving tracking flag to bug 1317191
status-firefox52: ? → ---
status-firefox53: ? → ---
tracking-firefox51: + → ---
tracking-firefox52: ? → ---
(Reporter)

Updated

10 months ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.