add some logging to LayerTreeInvalidation.cpp

RESOLVED FIXED in Firefox 53

Status

()

P3
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

53 Branch
mozilla53
Points:
---

Firefox Tracking Flags

(firefox53 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

Back in bug 1254134 I wrote a patch to add some logging stuff to LayerTreeInvalidation.cpp, so that if it produced invalid regions we could figure out where specifically the invalid regions were coming from. That patch was reviewed and landed, and later backed out because the fix for that bug caused other regressions. The logging however is still useful and I'd like to reland it. I rebased the patch (pretty trivial rebase).
Created attachment 8818342 [details] [diff] [review]
Patch

Carrying r+ from mattwoodrow in bug 1254134.
Attachment #8818342 - Flags: review+

Comment 2

2 years ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c927a4651936
Add debugging logs to LayerTreeInvalidation.cpp. r=mattwoodrow

Comment 3

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c927a4651936
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.