[es-CL] Inspector doesn't work due to shortcut issue in Firefox Developer Edition (FF52)

RESOLVED FIXED

Status

Mozilla Localizations
es-CL / Spanish (Chile)
RESOLVED FIXED
10 months ago
8 months ago

People

(Reporter: iformas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 months ago
Created attachment 8818431 [details]
capp.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20161211004007

Steps to reproduce:

Open dev tools (f12), select Inspector tab


Actual results:

Inspector in dev tools doesn't show anything, also the mouse selector doesn't work


Expected results:

Inspector should be showing web structure
(Reporter)

Updated

10 months ago
Component: Untriaged → Developer Tools: Inspector
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Updated

10 months ago
Summary: Inspector doesn't work - [ff dev ed - 52.0a2 2016-12-11 x64] → Inspector doesn't work - [ff dev ed - 52.0a2 2016-12-11]

Comment 1

10 months ago
I can't reproduce it with the latest DE build.

1) Could you update to the latest DE version.

2) Test with a new profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(iformas)

Comment 2

10 months ago
WFM in 52.0a2 (2016-12-13) (32-bit) on Win10.

Any error info on Browser Console?
(Reporter)

Comment 3

10 months ago
Created attachment 8818528 [details]
console.png

console ss
(Reporter)

Comment 4

10 months ago
Now tested in win 7 (x86), FD 52.0a2 (2016-12-13) (32-bit)
I deleted all profiles inside the profile manager, also I deleted the folders:
 AppData\Roaming\Mozilla
 AppData\LocalLow\Mozilla
 AppData\Local\Mozilla

..and tried Safe Mode but the problem persist

A console log ScreenShot was attached as "console.png", the error "TypeError: str is null" pop-ups when I switch to Inspector Tab


09:17:27.056 TypeError: str is null 1 key-shortcuts.js:97:7
	KeyShortcuts.parseElectronKey resource://devtools/client/shared/key-shortcuts.js:97:7
	on resource://devtools/client/shared/key-shortcuts.js:237:22
	Editor.prototype._initShortcuts/< resource://devtools/client/sourceeditor/editor.js:1285:7
	forEach self-hosted:251:13
	Editor.prototype._initShortcuts resource://devtools/client/sourceeditor/editor.js:1283:5
	Editor.prototype._setup resource://devtools/client/sourceeditor/editor.js:412:5
	Editor.prototype.appendToLocalElement resource://devtools/client/sourceeditor/editor.js:296:5
	HTMLEditor resource://devtools/client/inspector/markup/views/html-editor.js:60:3
	MarkupView resource://devtools/client/inspector/markup/markup.js:74:21
	Inspector.prototype._onMarkupFrameLoad chrome://devtools/content/inspector/inspector.js:1336:19
	bound  self-hosted:915:17

Comment 5

10 months ago
It can be reproduced with https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-aurora-l10n/firefox-52.0a2.es-CL.win32.zip

The error happened at view-source:resource://devtools/client/shared/key-shortcuts.js
KeyShortcuts.parseElectronKey = function (window, str) {
  let modifiers = str.split("+");


https://transvision.mozfr.org/?recherche=CmdOrCtrl&repo=aurora&sourcelocale=en-US&locale=es-CL&search_type=strings
There are three strings that are "Warning: Empty string"
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
Flags: needinfo?(iformas)

Comment 6

10 months ago
It's a shortcut issue in the locale es-CL, I guess. Because the version en-US is not affected.
Component: Developer Tools: Inspector → es-CL / Spanish (Chile)
Product: Firefox → Mozilla Localizations
Summary: Inspector doesn't work - [ff dev ed - 52.0a2 2016-12-11] → [es-CL] Inspector doesn't work due to shortcut issue in Firefox Developer Edition (FF52)
Version: 52 Branch → unspecified
Hi, the changes to the shortcuts have been pushed to the repo
http://hg.mozilla.org/releases/l10n/mozilla-aurora/es-CL/rev/54a5fe096619

Please, check in tomorrow's build
(Reporter)

Comment 8

10 months ago
Bug fixed in last build ;)
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.