Privacy Badger extension and maybe its variant causes TypeError: ERROR.captureStackTrace is not a function

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: esroyo, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161213204721

Steps to reproduce:

Visit this page: https://developer.mozilla.org/en-US/docs/Web/API/CanvasRenderingContext2D/fillText


Actual results:

The demo in the page is not working. Console shows:
"TypeError: ERROR.captureStackTrace is not a function"


Expected results:

Tha page should not throw a TypeError.

Comment 1

2 years ago
WFM with FF50.1.0 on Win 7.
Could you use the tool mozregression (with python 2.7) to narrow down a regression range, please.
http://mozilla.github.io/mozregression/

Run "mozregressionn --good=49" then copy here the final pushlog from mozilla-inbound.
Flags: needinfo?(esroyo)

Comment 2

2 years ago
WFM in Fx51.0b7 (64-bit) on Win10.

Reporter, what is the source of the error?

Updated

2 years ago
See Also: → bug 1323443

Updated

2 years ago
See Also: → bug 1323661
looks like this is an issue caused by Privacy Badger extension or its variant.
Status: UNCONFIRMED → NEW
Component: Untriaged → Extension Compatibility
Ever confirmed: true

Updated

2 years ago
Duplicate of this bug: 1323661

Updated

2 years ago
Duplicate of this bug: 1323443

Updated

2 years ago
Summary: CanvasRenderingContext2D.fillText() throws a TypeError → Privacy Badger extension and maybe its variant causes TypeError: ERROR.captureStackTrace is not a function
this happens with version 2016.12.8.1, but doesn't happen with version 1.9.2.

https://addons.mozilla.org/ja/firefox/addon/privacy-badger17/versions/
(Reporter)

Comment 8

2 years ago
Confirmed, disabling the extension solves the error.
I'm sorry, I should have checked without extensions before reporting.

This issue should be closed, right?

Thanks friends.

Comment 9

2 years ago
As it's already tracked on the Github repo of Privacy Badger, let's close this bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(esroyo)
Resolution: --- → WORKSFORME

Updated

2 years ago
Duplicate of this bug: 1323673

Updated

2 years ago
See Also: bug 1323443, bug 1323661
You need to log in before you can comment on or make changes to this bug.