Closed Bug 1323521 Opened 3 years ago Closed 3 years ago

Prevent Windows 10 touchscreens from launching a11y

Categories

(Core :: Widget: Win32, defect)

Unspecified
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla53
Tracking Status
firefox52 --- verified
firefox53 --- fixed

People

(Reporter: aklotz, Assigned: aklotz)

References

Details

(Whiteboard: [qf:p1])

Attachments

(1 file)

I think that I have cracked this nut...
Comment on attachment 8818621 [details]
Bug 1323521: Prevent Windows touchscreen support from instantiating a11y;

https://reviewboard.mozilla.org/r/98632/#review98938

Looks good, lets land on nightly and see how it goes.
Attachment #8818621 - Flags: review?(jmathies) → review+
Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/47b072202511
Prevent Windows touchscreen support from instantiating a11y; r=jimm
Depends on: 1323544
I'll re-push on inbound with a fixed patch that doesn't f up line endings.
https://hg.mozilla.org/integration/mozilla-inbound/rev/0e00689493b6e712340f902ccd5480b99815ccf9
Bug 1323521: Prevent Windows touchscreen support from instantiating a11y; r=jimm
https://hg.mozilla.org/mozilla-central/rev/0e00689493b6
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
This is great, Aaron should we (you) request uplift or would you like to try to solve the Windows 8 case first?
Flags: needinfo?(aklotz)
We can do this independently of the Windows 8 problem.
Flags: needinfo?(aklotz)
Comment on attachment 8818621 [details]
Bug 1323521: Prevent Windows touchscreen support from instantiating a11y;

Approval Request Comment
[Feature/Bug causing the regression]: Windows 10 touchscreens on e10s
[User impact if declined]: No touch support for Windows 10 on 52.
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Really simple patch.
[String changes made/needed]: None
Attachment #8818621 - Flags: approval-mozilla-aurora?
OS: Windows → Windows 10
Summary: Prevent Windows touchscreens from launching a11y → Prevent Windows 10 touchscreens from launching a11y
See Also: → 1325676
Comment on attachment 8818621 [details]
Bug 1323521: Prevent Windows touchscreen support from instantiating a11y;

Sounds good, we want to support the touchscreen without incorrectly poking the a11y API.
Attachment #8818621 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 1329616
Flags: qe-verify?
Per Comment 10, it was noted there are no steps to reproduce to be able to verify. Yet a flag is saying to do such.

Aaron, are there any preferences we would need to set or any way to see in about:support whether or not we know a11y is working [or prevented in this case] as intended? Or do we just go over the touch screen functionality and ensure that's working at all? Thanks.
Flags: needinfo?(aklotz)
Probably the best thing to do is to go through the touch screen functionality, make sure it is working, as you said. But then after doing all of that touchscreen stuff, go to about:support and check the Accessibility section. "Activated" should be false.
Flags: needinfo?(aklotz)
Working as intended with the following user agent:
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Status: RESOLVED → VERIFIED
Whiteboard: [qf:p1]
You need to log in before you can comment on or make changes to this bug.