crash [@ nsImapServerResponseParser::ProcessOkCommand ]

RESOLVED DUPLICATE of bug 628646

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED DUPLICATE of bug 628646
2 years ago
a year ago

People

(Reporter: Richard Leger, Unassigned)

Tracking

({crash})

crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.99 Safari/537.36

Steps to reproduce:

End-user was saving a draft email
or End-user going through Inbox search results (after global searching)

Both users using different Win 7 Pro 64 bits machine. Both Dell computers with SSD drive. Windows up-to-date. Drivers/Bios up-to-date. sfc /scannow report no errors. disk diagnostic reports no error. memory diagnostic reports no error. free space, memory consumption, cpu usage seems ok.

Thunderbird is the only application crashing on the computer.
User set with roaming profile but always using the same machine and rarely login off/on. IMAP account set to download only headers. IMAP Davical server on the same Local Area Network 1Gbps capable.


Actual results:


Application crashed!

Happened to multiple users at multiple occasions...

Thunderbird 45.5.1 Crash Report [@ nsImapServerResponseParser::ProcessOkCommand ]
bp-eca552f4-ffe6-4343-b45f-fc8172161213     13/12/2016    14:08 MM
https://crash-stats.mozilla.com/report/index/eca552f4-ffe6-4343-b45f-fc8172161213
Note: End-user was saving a draft email

Thunderbird 45.5.0 Crash Report [@ nsImapServerResponseParser::ProcessOkCommand ]
bp-d1881fa2-3d8d-4dce-b41d-3a8472161130     30/11/2016    11:35 MM
https://crash-stats.mozilla.com/report/index/d1881fa2-3d8d-4dce-b41d-3a8472161130
KERNELBASE.dll         6.1.7601.23569         559826121FFA46DFA4A74D1AF319182C1 wkernelbase.pdb
kernel32.dll         6.1.7601.23569         AB6B617AB7E1496AB63555DEBF8A91B12 wkernel32.pdb
ntdll.dll         6.1.7601.23569         E8115772097C49E1B552D29E17AD30DD2         wntdll.pdb
Note: End-user going through Inbox search results (after global searching)

Thunderbird 45.4.0 Crash Report [@ nsImapServerResponseParser::ProcessOkCommand ]
bp-5398b516-033c-4bd7-ad45-c43892161025     25/10/2016    12:33 MM

Thunderbird 45.2.0 Crash Report [@ nsImapServerResponseParser::ProcessOkCommand ]
bp-658dc423-34c7-487f-9d2e-78a7d2160913     13/09/2016    16:14 SD


Expected results:


Application shall have not crashed and completed task triggered by end-user :-)
(Reporter)

Updated

2 years ago
Summary: [@ nsImapServerResponseParser::ProcessOkCommand ] → crash [@ nsImapServerResponseParser::ProcessOkCommand ]

Comment 1

2 years ago
When a new bug report is needed, please use "Bugzilla - Report this bug in Thunderbird" link found in the crash report - it fills in all the relevant fields

Note, in this case no new bug report is needed.  Crash reports have a section titled "Related Bugs" which in this case points to bug 628646.
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Keywords: crash
Resolution: --- → DUPLICATE
Duplicate of bug: 628646
(Reporter)

Comment 2

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #1)
> When a new bug report is needed, please use "Bugzilla - Report this bug in
> Thunderbird" link found in the crash report - it fills in all the relevant
> fields

The problem for me is that I don't always have sufficient time on the machine having the issue itself to do so directly from Thunderbird but I'll try to do in the future in measure of possible...

> Note, in this case no new bug report is needed.  Crash reports have a
> section titled "Related Bugs" which in this case points to bug 628646.

Does that mean the crash report is automatically already linked to that existing bug? Or I still need to submit the report for that to be the case so the crash report is linked to the existing bug?

Comment 3

2 years ago
(In reply to Richard Leger from comment #2)
> (In reply to Wayne Mery (:wsmwk, NI for questions) from comment #1)
> > When a new bug report is needed, please use "Bugzilla - Report this bug in
> > Thunderbird" link found in the crash report - it fills in all the relevant
> > fields
> 
> The problem for me is that I don't always have sufficient time on the
> machine having the issue itself to do so directly from Thunderbird but I'll
> try to do in the future in measure of possible...

It couldn't be any faster or simpler - you click on the crash ID in Thunderbird, if you don't see a bug under "related" then you click "Thunderbird", it creates a bug with everything filled in and you click "Save. done.
 
> > Note, in this case no new bug report is needed.  Crash reports have a
> > section titled "Related Bugs" which in this case points to bug 628646.
> 
> Does that mean the crash report is automatically already linked to that
> existing bug? 

yes - for SUBMITTED crashes.

> Or I still need to submit the report for that to be the case
> so the crash report is linked to the existing bug?

certainly, you or the user need to make sure you submit crash reports reports. But you don't need to file another bug report

Updated

a year ago
Blocks: 1313774
You need to log in before you can comment on or make changes to this bug.