Assertion failure: false (GFX: We should have caught all other errors.), at c:/mozilla-source/mozilla-central/dom/canvas/WebGLTextureUpload.cpp:1460

RESOLVED DUPLICATE of bug 1315866

Status

()

Core
Canvas: WebGL
RESOLVED DUPLICATE of bug 1315866
2 years ago
2 years ago

People

(Reporter: vliu, Assigned: vliu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
The Assertion failure happens by running [1] on current Nightly build.

[1]: https://github.com/KhronosGroup/WebGL/blob/master/conformance-suites/2.0.0/deqp/functional/gles3/negativetextureapi.html
(Assignee)

Comment 1

2 years ago
A first look into this, the crash point should be in [1]. If I tried to modify log2MaxTextureSize to 0, the crash didn't happens, either.


[1]: https://github.com/KhronosGroup/WebGL/blob/master/conformance-suites/2.0.0/deqp/functional/gles3/es3fNegativeTextureApiTests.js#L2545
(Assignee)

Updated

2 years ago
Assignee: nobody → vliu
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1315866
You need to log in before you can comment on or make changes to this bug.