Status

()

Firefox
Screen Sharing Whitelist
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: Adam Palinkas, Unassigned)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
>> Vendor name
Telebond

>> Point of contact
adam.palinkas@telebond.com

>> Site URLs
*.telebond.com

>> Does the application provide users with notice and control?
Hi There - 

Telebond is a software for professional video consultations. We give our users clean and straightforward way to share the screen and always show which stream (camera or screen) they are broadcasting to the other party. Users can turn on and off screen sharing without any obfuscation or indirect behaviour.

Please find the privacy notice on our terms of use page: https://telebond.com/terms/#

I'd like to ask how the process actually works, if we are qualified to be whitelisted in Firefox browser does it happen with the next release?

How much time does it take usually to be whitelisted in the browser? We would like to inform our users and roll out the feature accordingly if it's possible to give a time frame for that.

Also we are open to any requests you might think is required to conform with Firefox user experience.

Thanks,
Adam

>> Have you seen and agree with the Developer Screen Sharing Submission policy?
Yes

>> Does the usage comply with the Developer Screen Sharing Submission Policy guidelines?
Yes

Comment 1

a year ago
Hi, I am resolving this bug as "won't fix", since starting Firefox 52 on April 18th the Screensharing whitelist is no longer needed to share your screen or windows. Please let us know if you find any problems!

        Much of this work was front-end, UX/UI changes, including support to let the UI know what streams are "scary" to share (see bug 1284910). See the meta bug 1127522 for all the work that went into this.

        Please read Jan-Ivar's blog post explaining the risks that users need to know about when sharing their screen or windows: https://blog.mozilla.org/webrtc/share-browser-windows-entire-screen-sites-trust/.

        The new UI permission dialog for screensharing links to a SUMO article with similar content to Jan-Ivar's post, but our SUMO team tailored it to a less technical user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.