If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

bus error if you "go back one page" on a specific website

RESOLVED DUPLICATE of bug 125784

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 125784
16 years ago
12 years ago

People

(Reporter: Dominic Burghartswieser, Assigned: asa)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.9) Gecko/20020315
BuildID:    20020315

if i visit ipc2u.de and use a search engine, mozilla will crash with a "bus
error" if i hit "go back one page" once.

Reproducible: Sometimes
Steps to Reproduce:
1. visit http://www.ipc2u.de
2. chose "chassis"
3. chose some search options (i chose '19"...' and '1' as height unit)
4. let it search
5. after the next page loaded hit "go back one page"

Actual Results:  mozilla crashes with a "bus error" (no more error messages)

Expected Results:  it shouldn't crash?!

Comment 1

16 years ago
reporter: I tried following your steps to reproduce but could not, i'm pretty 
sure you skipped steps,

the steps i took:
~/mozilla/obj-gtk-i386-unknown-freebsd4.4/dist/bin: ./mozilla 
http://www.ipc2u.de
click catalog
click 19" chassis
click {browser}back
This is almost certainly a duplicate of a known form state restoration crasher
in 0.9.9 which has been fixed since.  I cannot reproduce the crash with a
current build..

Could you please use a talkback build so that we can get a stack and then be
able to tell for sure?
(Reporter)

Comment 3

16 years ago
there is no talkback build available for me and configure won't tell me how to
build mozilla with talkback capabilities.

$ ./configure --help|grep talk
Ah, right... You can't build talkback -- it's not open source.

Could you possibly just get a latest nightly and test with that?
(Reporter)

Comment 5

16 years ago
a current nightly snapshot seems to fix the problem - mozilla won't crash
anymore on this ocassion.
Dominic, thanks for testing!  Marking duplicate of the 0.9.9 crasher that
illustrated all the same symptoms on pages like this one (and that's the crash
_I'm_ seeing on this page with 0.9.9).

*** This bug has been marked as a duplicate of 125784 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.