Crash in igd11dxva32.dll | BaseThreadInitThunk

RESOLVED DUPLICATE of bug 1322554

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1322554
2 years ago
2 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

({crash, regression})

52 Branch
All
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-1031f058-3d5c-4e9d-97be-674b22161215.
=============================================================
Ø 0 	igd11dxva32.dll 	igd11dxva32.dll@0x48f5d 	
Ø 1 	igd11dxva32.dll 	igd11dxva32.dll@0x4de4f 	
Ø 2 	igd11dxva32.dll 	igd11dxva32.dll@0x294f1 	
Ø 3 	igd11dxva32.dll 	igd11dxva32.dll@0xad1db 	
Ø 4 	igd11dxva32.dll 	igd11dxva32.dll@0xafd75 	
Ø 5 	igd11dxva32.dll 	igd11dxva32.dll@0x200696 	
Ø 6 	igd11dxva32.dll 	igd11dxva32.dll@0x2134f9 	
Ø 7 	igd11dxva32.dll 	igd11dxva32.dll@0x4b8155 	
Ø 8 	igd11dxva32.dll 	igd11dxva32.dll@0x4b829c 	
9 	kernel32.dll 	BaseThreadInitThunk 	
10 	ntdll.dll 	__RtlUserThreadStart 	
11 	ntdll.dll 	_RtlUserThreadStart 	
=============================================================
More reports: https://crash-stats.mozilla.com/signature/?product=Firefox&signature=igd11dxva32.dll%20%7C%20BaseThreadInitThunk

Correlations:
> (100.0% in signature vs 02.18% overall) Module "igd11dxva32.dll" = true
> (100.0% in signature vs 04.58% overall) Module "MSVP9DEC.dll" = true
> (99.17% in signature vs 02.73% overall) Module "igc32.dll" = true
> (100.0% in signature vs 09.85% overall) Module "msvproc.dll" = true
> (100.0% in signature vs 10.35% overall) "DXVA2D3D11+" in app_notes = true
> (100.0% in signature vs 11.27% overall) "DXVA2D3D11?" in app_notes = true
> (100.0% in signature vs 14.34% overall) reason = EXCEPTION_ACCESS_VIOLATION_READ
> (100.0% in signature vs 17.15% overall) Module "igd10iumd32.dll" = true
> (100.0% in signature vs 18.30% overall) Module "ntasn1.dll" = true
> (100.0% in signature vs 23.97% overall) Module "ncrypt.dll" = true
> (99.17% in signature vs 22.08% overall) Module "mfperfhelper.dll" = true
> (99.17% in signature vs 24.05% overall) Module "MSAudDecMFT.dll" = true
> (100.0% in signature vs 27.20% overall) Module "RTWorkQ.dll" = true
> (100.0% in signature vs 29.34% overall) os_arch = amd64
> (76.03% in signature vs 04.06% overall) CPU Info = GenuineIntel family 6 model 94 stepping 3
> (100.0% in signature vs 36.95% overall) platform_version = 10.0.14393
> (100.0% in signature vs 39.08% overall) Module "WinTypes.dll" = true
> (100.0% in signature vs 39.60% overall) Module "win32u.dll" = true
> (100.0% in signature vs 39.60% overall) Module "gdi32full.dll" = true
> (100.0% in signature vs 40.82% overall) Module "avrt.dll" = true
> (89.26% in signature vs 28.11% overall) Module "ondemandconnroutehelper.dll" = true
> (100.0% in signature vs 44.54% overall) Module "windows.storage.dll" = true
> (100.0% in signature vs 44.78% overall) platform_pretty_version = Windows 10
> (100.0% in signature vs 46.42% overall) Module "evr.dll" = true
> (100.0% in signature vs 46.42% overall) Module "mf.dll" = true
> (99.17% in signature vs 44.79% overall) Module "msmpeg2vdec.dll" = true
> (100.0% in signature vs 46.79% overall) Module "dxva2.dll" = true
> (100.0% in signature vs 47.41% overall) Module "mfplat.dll" = true
> (100.0% in signature vs 48.13% overall) Module "mozavcodec.dll" = true
> (100.0% in signature vs 48.14% overall) Module "mozavutil.dll" = true
> (100.0% in signature vs 49.24% overall) Module "softokn3.dll" = true
> (100.0% in signature vs 49.32% overall) Module "freebl3.dll" = true
> (89.26% in signature vs 34.75% overall) Module "winhttp.dll" = true
> (100.0% in signature vs 52.97% overall) Module "kernel.appcore.dll" = true
> (100.0% in signature vs 53.88% overall) Module "WINMMBASE.dll" = true
> (100.0% in signature vs 54.19% overall) Module "SHCore.dll" = true
> (100.0% in signature vs 54.22% overall) Module "bcryptPrimitives.dll" = true
> (100.0% in signature vs 54.23% overall) Module "combase.dll" = true
> (100.0% in signature vs 55.50% overall) adapter_vendor_id = Intel Corporation
> (51.24% in signature vs 00.60% overall) adapter_driver_version_clean = 4454
> (51.24% in signature vs 00.60% overall) adapter_driver_version = 20.19.15.4454
> (52.89% in signature vs 02.38% overall) adapter_device_id = 0x191b
> (64.46% in signature vs 15.45% overall) has dual GPUs = true
> (100.0% in signature vs 59.58% overall) Module "xmllite.dll" = true
> (100.0% in signature vs 61.08% overall) Module "DWrite.dll" = true
> (86.78% in signature vs 42.76% overall) Module "msvcp_win.dll" = true
> (100.0% in signature vs 63.47% overall) Module "d3d11.dll" = true
> (100.0% in signature vs 63.66% overall) Module "dxgi.dll" = true
> (100.0% in signature vs 64.36% overall) Module "CRYPTBASE.dll" = true
> (100.0% in signature vs 64.51% overall) "D2D1.1+" in app_notes = true
> (99.17% in signature vs 63.88% overall) Module "cryptsp.dll" = true
> (100.0% in signature vs 68.02% overall) cpu_arch = x86
> (100.0% in signature vs 68.15% overall) Module "bcrypt.dll" = true
> (100.0% in signature vs 68.46% overall) Module "d2d1.dll" = true
> (71.07% in signature vs 32.31% overall) Module "wshbth.dll" = true
> (51.24% in signature vs 13.57% overall) Module "cabinet.dll" = true
> (100.0% in signature vs 72.78% overall) Module "pnrpnsp.dll" = true
> (100.0% in signature vs 72.97% overall) Module "nlaapi.dll" = true
> (100.0% in signature vs 72.97% overall) Module "NapiNSP.dll" = true
> (34.71% in signature vs 00.14% overall) address = 0x398
> (100.0% in signature vs 75.24% overall) Module "winrnr.dll" = true
> (100.0% in signature vs 75.53% overall) "DWrite+" in app_notes = true
> (100.0% in signature vs 75.54% overall) "DWrite?" in app_notes = true
> (55.37% in signature vs 23.19% overall) Module "d3dcompiler_47.dll" = true
> (31.40% in signature vs 00.23% overall) adapter_subsys_id = 07061028
> (100.0% in signature vs 76.79% overall) Module "dnsapi.dll" = true
> (100.0% in signature vs 77.03% overall) Module "firefox.exe" = true
> (100.0% in signature vs 77.14% overall) Module "mswsock.dll" = true
> (41.32% in signature vs 10.66% overall) Module "WMVCORE.DLL" = true
> (41.32% in signature vs 10.70% overall) Module "WMASF.DLL" = true
> (31.40% in signature vs 01.34% overall) cpu_microcode_version = 0x84
> (100.0% in signature vs 78.87% overall) Module "AudioSes.dll" = true
> (100.0% in signature vs 78.87% overall) Module "powrprof.dll" = true
> (100.0% in signature vs 79.42% overall) Module "MMDevAPI.dll" = true
> (39.67% in signature vs 11.09% overall) bios_manufacturer = Dell Inc.
> (89.26% in signature vs 64.84% overall) Module "wininet.dll" = true
> (89.26% in signature vs 65.60% overall) Module "iertutil.dll" = true
> (52.89% in signature vs 27.26% overall) Addon "Adblock Plus" = true
> (38.02% in signature vs 13.42% overall) Module "dcomp.dll" = true
> (23.14% in signature vs 01.83% overall) CPU Info = GenuineIntel family 6 model 78 stepping 3
> (22.31% in signature vs 01.55% overall) adapter_driver_version_clean = 4463
> (22.31% in signature vs 01.55% overall) adapter_driver_version = 20.19.15.4463
> (22.31% in signature vs 01.94% overall) useragent_locale = es-MX
> (19.01% in signature vs 00.20% overall) adapter_driver_version_clean = 4364
> (19.01% in signature vs 00.20% overall) adapter_driver_version = 20.19.15.4364
> (37.19% in signature vs 16.78% overall) Module "libEGL.dll" = true
> (37.19% in signature vs 16.79% overall) Module "libGLESv2.dll" = true
> (19.83% in signature vs 01.03% overall) adapter_device_id = 0x1912
> (37.19% in signature vs 16.99% overall) "EGL+" in app_notes = true
> (20.66% in signature vs 01.99% overall) adapter_device_id = 0x1916
> (37.19% in signature vs 17.23% overall) "EGL?" in app_notes = true
> (16.53% in signature vs 00.20% overall) Addon "YouTube Video Player Speed" = true
> (19.83% in signature vs 03.46% overall) useragent_locale = es-ES
> (16.53% in signature vs 01.19% overall) Addon "McAfee SiteAdvisor" = true

This is the #19 crash in Aurora overall (0.40%). Based on reports it looks like this is a regression in Aurora 52.0a2 20161121004022. There are several GFX related changes and I'm not sure which is the culprit:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=e59ed8b3ba13fd33435eea75da37ea6029c9af40&tochange=a99c9599b45835479e6e18da0614b0652d42435a

97% of these crashes are reported on Skylake-GT2 chipsets (65% are on Intel HD 530) with driver versions ranging from 20.19.15.4326 to 20.19.15.4463 (54% are on 20.19.15.4454). The latest driver, 21.20.16.4542, does not show up at all in crashes so maybe this can be mitigated with a blocklist.

Most of the URLs are youtube.com, perhaps unsurprisingly.
Flags: needinfo?(milan)
This looks like a duplicate of bug 1322554, just isolated to particular hardware, right?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(milan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1322554
You need to log in before you can comment on or make changes to this bug.