Closed Bug 132385 Opened 18 years ago Closed 17 years ago

Select View|Show Name As via mnemonics, menu items not checked

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

All
Windows ME
defect
Not set

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: nbaca, Assigned: sspitzer)

References

Details

(Keywords: access, polish, Whiteboard: [ue3])

Trunk build 2002-03-20: WinMe, Linux RH 7.1

Overview: Use mnemonics to manipulate the Show Name As menu items and notice 
that the checkmark is not updated, it remains on the same menu item.

Steps to reproduce:
1. Go to the View|Show Name As menu to see its current settings (i.e. First, 
Last)
2. Select Alt+V to access the View menu
3. Type "N" for Show Name As menu option
4. Choose a different option, for instance "D" for Display Name

Actual Results: It performs the function so now the names are displayed 
according to Display Name but the View|Show Name As|Display Name menu item is 
not checked.

If the mouse is used then the checkmarks work as expected.

Expected Results: The checkmark listed in View|Show Name As should reflect the 
current state (i.e. Display Name).
Marking nsbeta1 because this may be important for accessibility reasons.
Assignee: racham → sspitzer
Keywords: access, nsbeta1
This problem occurs when using mnemonics so changing the Summary from
Select View|Show Name As via keyboard, menu items not checked" to 
"Select View|Show Name As via mnemonics, menu items not checked"
Summary: Select View|Show Name As via keyboard, menu items not checked → Select View|Show Name As via mnemonics, menu items not checked
nsbeta1- since it works.
Keywords: nsbeta1nsbeta1-
Whiteboard: [ue]
Blocks: 156960
Keywords: nsbeta1-nsbeta1, polish
Whiteboard: [ue] → [ue3]
Trunk build 2002-12-20: Linux 8.0
Trunk build 2002-12-23: Win2k
Marking Worksforme.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
Verified Worksforme.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.