mach bootstrap doesn't install android build-tools 23.0.3

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: glandium, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
As a matter of fact, it installed no version of build-tools at all (no build-tools directory), and the build fails with:

DEBUG: configure: error: You must install the Android build-tools version 23.0.3.  Try |mach bootstrap|.  (Looked for /home/glandium/.mozbuild/android-sdk-linux/build-tools/23.0.3)

Running the android tool and installing build-tools 23.0.3 worked around the issue.

Comment 1

a year ago
Duplicate of bug 1280165?
Faced the same problem today.
(In reply to Elena Muravyova [:moraveyo] from comment #2)
> Faced the same problem today.

New |mach bootstrap| should install build-tools 25.0.3, per http://searchfox.org/mozilla-central/source/python/mozboot/mozboot/android-packages.txt#2.

This should have been addressed by https://bugzilla.mozilla.org/show_bug.cgi?id=1366644.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.