Closed Bug 1323996 Opened 3 years ago Closed 3 years ago

"COMPtrTypes.h(17): error C2371: 'mozilla::a11y::IAccessibleHolder': redefinition; different basic types" with --disable-accessibility

Categories

(Core :: Disability Access APIs, defect)

All
Windows
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: RyanVM, Assigned: aklotz)

References

Details

Attachments

(1 file)

10:07.93 c:\Users\Ryan\repos\mozilla-central\objdir-fx-64\dist\include\mozilla/a11y/COMPtrTypes.h(17): error C2371: 'mozilla::a11y::IAccessibleHolder': redefinition; different basic types
10:07.94 c:\Users\Ryan\repos\mozilla-central\objdir-fx-64\dist\include\mozilla/a11y/IPCTypes.h(41): note: see declaration of 'mozilla::a11y::IAccessibleHolder'

Fallout from bug 1314707 it appears.
I'm a bit confused about this one since IPCTypes.h seems to have defined(ACCESSIBILITY) guards in place? I did try clobbering to make sure it wasn't some local state issue. It also reproduces on Try.
Flags: needinfo?(aklotz)
Which source file(s) were failing to compile due to these errors?
Flags: needinfo?(aklotz) → needinfo?(ryanvm)
Attached patch FixSplinter Review
Assignee: nobody → aklotz
Status: NEW → ASSIGNED
Attachment #8819374 - Flags: review?(tbsaunde+mozbugs)
Comment on attachment 8819374 [details] [diff] [review]
Fix

fwiw, it would be easier to review this if the commit message explained why it is needed.
Attachment #8819374 - Flags: review?(tbsaunde+mozbugs) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/c141ad08e219041aa5505fe925d086e3a93df0b9
Bug 1323996: Make PDocAccessible.ipdl import IAccessibleHolder from IPCTypes.h to fix --disable-accessibility build failures; r=tbsaunde
https://hg.mozilla.org/mozilla-central/rev/c141ad08e219
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8819374 [details] [diff] [review]
Fix

Approval Request Comment
[Feature/Bug causing the regression]: bug 1314707
[User impact if declined]: None. Breaks --disable-accessibility builds
[Is this code covered by automated tests?]: N/A
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: Depends on bug 1314707 being uplifted
[Is the change risky?]: No
[Why is the change risky/not risky?]: This fix affects non-default build configurations; it does not affect the builds that we ship.
[String changes made/needed]: None
Attachment #8819374 - Flags: approval-mozilla-aurora?
Comment on attachment 8819374 [details] [diff] [review]
Fix

followup build fix for bug 1314707, for aurora52
Attachment #8819374 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
had to back this out for bustage like https://treeherder.mozilla.org/logviewer.html#?job_id=4509730&repo=mozilla-aurora
Flags: needinfo?(aklotz)
You need to log in before you can comment on or make changes to this bug.