if email message subject is blank, POP3 message filter on body fails

VERIFIED FIXED in M18

Status

P1
normal
VERIFIED FIXED
20 years ago
10 years ago

People

(Reporter: ekrock, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #362652
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=362652
Imported into Bugzilla on 09/07/99 10:55)

Nav4.61 on WinNT 4.0 SP3.

To repro:
1) Create an aka alias "marek-signup" with distribution to QA tester
(marek@netscape.com?)
2) open Messenger
3) create new folder marek-signup
4) create subfolder of marek-signup called Day1Standards
5) Edit-->Message Filters
6) create a new filter:
  a) check "All of the following"
  b) to or cc: includes marek-signup@netscape.com
  c) body contains Day1Standards=yes
  d) move to Day1Standards
7) create a second filter, after the first in the filter order:
  a) check "All of the following"
  b) to or cc: includes marek-signup@netscape.com
  d) move to marek-signup

Now, a message sent to marek-signup@netscape.com with Day1Standards=yes in the
body should move to Day1Standards; all others sent to marek-signup@netscape.com
should move to marek-signup.

But now test it:

8) open WebMail
9) send a message to marek-signup@netscape.com with a blank subject and
Day1Standards=yes in the body
10) the message winds up in marek-signup, not in Day1Standards; the first rule
failed to execute. If the subject is not blank, the first rule works fine.

Mainly I want to be sure the same bug doesn't occur in Nav5.


------- Additional Comments From marek  Sep-07-1999 10:27 -------

assigning to phil for 5.0 consideration.

Updated

20 years ago
Assignee: phil → bienvenu
Priority: P1
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
(Assignee)

Comment 1

20 years ago
I don't believe it for a second, but I'll see if it happens in 5.0 (actually, I
can't, because body filters don't work yet)
(Reporter)

Comment 2

19 years ago
FYI, I've seen this happen in Nav 4.6 on WinNT 4.0 SP3 myself, so I believe this
is a real bug.  During the CodeStock registration, we received submissions by
email form submit from a variety of browsers.  If the browser produced a blank
subject line, the filters we'd set up (which included tests on the body) tended
to fail.  The CodeStock registration form is at
http://www.mozilla.org/newlayout/signup.html

Not certain which browsers were generating the blank subject line submissions.
I believe that email messages with a Subject of "(no subject)" or "Unidentified
subject!" were failing to filter. FWIW.
(Assignee)

Comment 3

19 years ago
moving to m16
Target Milestone: M15 → M16

Comment 4

19 years ago
Not beta2 stopper, marking M17.
Target Milestone: M16 → M17

Comment 5

19 years ago
moving to future.
Target Milestone: M17 → Future
(Assignee)

Comment 6

19 years ago
adding nsbeta3 keyword
Keywords: nsbeta3
(Assignee)

Updated

19 years ago
Keywords: correctness
Target Milestone: Future → M18
(Assignee)

Comment 7

19 years ago
I want to see if this bug exists in 6.0
(Assignee)

Comment 8

19 years ago
seems to work fine in 6.0
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
Verifying this bug.

Comment 10

18 years ago
Messenger->Edit-->Message Filters->New filter does not have "body" field in it.
Cannot reproduce step 6c. Is this a bug? I dont see this field in 4.x either. 
Filed bug 56781 for the missing field.
(Assignee)

Comment 11

18 years ago
body filters only exist for pop, not for imap.

Updated

18 years ago
QA Contact: laurel

Comment 12

18 years ago
OK using jan08 commercial trunk build, win98
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.