Closed Bug 1324244 Opened 8 years ago Closed 8 years ago

"http://" is not a valid URL

Categories

(Core :: Networking, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1275746

People

(Reporter: manishearth, Assigned: manishearth)

References

Details

Attachments

(1 file)

We currently parse "http://" and "ftp://" as valid URLs. They are not.

See https://url.spec.whatwg.org/#hostname-state, special schemes (https://url.spec.whatwg.org/#special-scheme) cannot have empty hosts.

Chrome agrees with the spec here.
I'm not sure if this is the right place to do this check, or if I should do it in nsURLParsers.cpp. nsURLParsers.cpp seems to be a bit more general.
Assignee: nobody → manishearth
Status: NEW → ASSIGNED
We tried to fix this a few months ago, but it got backed out because it triggered a regression in the HTML form validator.
I'll try to land it as soon as the form bug gets fixed.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: