In some cases a weird screen is displayed instead of a "Server not found" message

RESOLVED DUPLICATE of bug 569229

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 569229
a year ago
a year ago

People

(Reporter: Kaartic Sivaraam, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8819643 [details]
Server not found not displayed

In some circumstances (not known exactly) trying to load a page when the device is offline shows a weird screen (see attached screen shot) instead of showing a "Server not found" error.

Steps to reproduce:
Probably will be provided later, if a consistent way for reproducing this is found

Expected behaviour:
"Server not found" message is displayed at all times when a page is tyring to be loaded when device is offline.

Actual behaviour:
In some cases a weird page (see attached screen shot) is displayed instead of the "Server not found" message
(Reporter)

Comment 1

a year ago
I suspect this happens when a different page of the same site is found in the cache.
This looks a lot like the error page we show when parsing an internal page fails - except that it doesn't show an error message.

Would be interesting to know how to reproduce this.
This is just the Android version of the XML parsing failure bug. It happens sometimes when you interrupt the loading of the page.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569229
You need to log in before you can comment on or make changes to this bug.