bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

new message filters are not saved when running without administrator privilegies



a year ago
a year ago


(Reporter: zetka, Unassigned)


45 Branch
Windows 7

Firefox Tracking Flags

(Not tracked)



(1 attachment)



a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

Having Imap configured folder and some local folders for filtering.
I added new filter.
I see it in the filter list.
I try to run it.

Actual results:

The message filter(s) is not running (no activity after pressing RUN now button).
After closing and reopeing the Thunderbird (45.5.1) the new added filter is not in the list.
There is no change (saving) on the msgfilterrules.dat 
In case of doing previous steps when runing Thunderbird with administrator privilegies, the filter is correctly added to the list and saved to the filter.
The directory with the file contains many msgfilterrules-xx.dat files with zero size where xx are increased numbers from 1 to 29 in my case .

Expected results:

Fiter rule have to be saved after closing Thunderbird in all modes.
MSgfilters should be working in any modes.


a year ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86

Comment 1

a year ago
Thunderbird stores filters in msgfilterrules.dat in the user's profile as many other files as well.

You're already saying that the new filter doesn't even run, so perhaps there is something wrong with the filter definition or the filter causes an access attempt on a read or write protected file in the user's profile.

Are there any messages in the error console?

Altogether this appears to be a Windows problem were some files in there user's profile can't be accessed. How about you make sure that all files in the user's profile have correct access rights. You know how to do this in Windows? Folder Properties, Security, Advanced, change/fix the owner and the permissions.

Comment 2

a year ago
I have attached screenshot of the error console. The entries are the same when starting under normal or administrator privilegies. I have verifed, that me has all rights to TB files as the administrator, but the new filters or any editing is not saved. When opening TB with normal priviliegies, the already saved filters are working.

Comment 3

a year ago
Created attachment 8820033 [details]
thunderbird error.jpg

the screenshot of the error console.

Comment 4

a year ago
Maybe a hint - when I tried to search for the manifest.chrome, I have found it on system disk C: under

Comment 5

a year ago
The "system disk C:" by default is also home to the user directories in
C:\Users\xxx\ and the profiles are in
Nothing surprising here unless the user doesn't have write access to his own directory.

Comment 6

a year ago
Maybe, but if you look to the screenshot, the directory, where Thunderbird searches is on D:, where is the mail folder. So the installation puts the files to the different location and TB searches it where it is not.

Comment 7

a year ago
All the screenshot shows me is that you have "Program Files" on D: and that the your Windows 7 is 32bit. On my 64bit system I see:
Could not read chrome manifest 'file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird%2045%20ES/chrome.manifest'.

The other error about 972ce4c67e08-4474-a285-3208198ce6fd is also "normal", see bug 586610 comment #40.

Nothing of this has to do with the rules. I'm not going to answer any more in this bug unless you follow what I said in comment #1 and make sure the user has access to all files in his/her profile.

Comment 8

a year ago
I understand. Let us go back to rules. I have done that what you said in comment #1, I verified, that all files have -r-a-s-h attributes and the access for the user is the same as for the administrator, verifed it in profiles, in the D:\program files... where is the TB files and D:\mail, where are the mail folders.
But still it behaves the same.
Maybe this can have something together with another difference between the behavior in normal and administrator mode. 
One mail local directory in case of administrator mode is normaly visible and all mails inside. I could even to rename it.
 In case of normal mode, I see the directory, but when I click on it, the contens of it is not displayed, and in the left top corner a green circle is turning. I tried to copy the file containing the mails under a new name, in such case I see it  after new starting and doing msf file as new folder  and I can see all files inside.
In case of trying of renaming the this folder to original name (which the folder had before I changed it the name under administrator privilegies), I am getting the error:
"The folder can not be renamed. Perhaps the folder is being reparsed or the new name is not valid folder name."  
I was not able to find, what this error means.
I am sorry to bother, but I do not know, what to do next. Maybe we could arrange a skype call and we can use it through teammviewer... I speak german too.

Comment 9

a year ago
(In reply to zetka from comment #8)
>  In case of normal mode, I see the directory, but when I click on it, the
> contens of it is not displayed, and in the left top corner a green circle is
> turning.
Looks like the is a problem with access rights here.

I can take a look in Teamviewer, although we usually don't provide individual support. We have 25 million users and if only 1% are using filters, that's still a large number and we'd get lots of complaints if this didn't work.

Comment 10

a year ago
Concerning the not working filters, it seems in some way similar to https://bugzilla.mozilla.org/show_bug.cgi?id=697106, but I will try again to find the differences in the rules. I have parrallely installed SeaMonkey with other email account, so I can compare the folder rules.

Comment 11

a year ago
Hello Jorg,
finally you were right with the rules. Some of the files inclusive the filterlog.html have limited rules for user, I had to change it manually when I disovered it. After correcting that, now the filters could be saved.
When I thought how that could happen, I suppose that it has something to do, when I recovered the profile from Mozbackup. I will sure observe it, what will be happening after this.
Best regards and thanks,

Comment 12

a year ago
Thanks for letting us know. Mozbackup is not an officially endorsed tool.
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697106
You need to log in before you can comment on or make changes to this bug.