If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Activity stream - No source icon and text are updated in the Highlights area when a visited website is bookmarked

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
9 months ago
3 months ago

People

(Reporter: carmenf, Unassigned)

Tracking

(Blocks: 1 bug)

53 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

(Whiteboard: [MobileAS])

(Reporter)

Description

9 months ago
Environment: 
Device: Prestigio Grace x5 (Android 4.4.2);
Build: Nightly 53.0a1 (2016-12-19);

Prerequisites:
Activity stream panel is populated with visited websites.

Steps to reproduce:
1. Launch Firefox;
2. Tap on 3 dots menu from a “Visited” website in the Highlights area;
3. Tap on “Bookmark” option from the context menu.
 
Expected result:
The “Visited” source icon and text are updated and replaced with the “Bookmarked” icon and text.

Actual result:
The “Visited” source icon and text are still displayed under the title of the Website.

Notes:
This is reproducible on both Phone and Tablet devices.
By accessing the context menu again after bookmarking the website, it shows that the website was bookmarked.
After bookmarking a website from Highlights area, I have also tried other ways to see if the “Visited” icon and text are updated, but this was unsuccessfully:
- by opening a new tab;
- by accessing a website (different from the bookmarked one), then going back to Activity stream panel;
- by closing Firefox from Task Manager, then opening it again.
The only way that the source gets updated is to access the recently bookmarked website.
(Reporter)

Updated

9 months ago
Whiteboard: [MobileAS]
Blocks: 1311099
This seems to be fixed already. Please reopen if this is still an issue.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.