Incorrect User Agent for 50.1

RESOLVED WONTFIX

Status

()

Firefox
Untriaged
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: whatismybrowser, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.71 Safari/537.36

Steps to reproduce:

Open Firefox Menu -> About Firefox
Look at version number: "50.1.0"
whatismybrowser.com -> look at user agent "[...] Firefox/50.0"


Actual results:

The version fragment "50.0" in the user agent is incorrect.


Expected results:

It should be "50.1" as this is what the About Firefox window says.

I run whatismybrowser.com and a number of people have reported this same issue to me (complaining that the "firefox is out of date" warning is incorrect - it isn't, the problem seems to be Firefox's user agent is incorrect).

Comment 1

a year ago
hi, this is by design. we only reveal the major version number to websites but not the patch level of the browser.

Comment 2

a year ago
please also see bug 728831 & bug 870868 as historical background on this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

a year ago
Thanks for the reply philipp.

I still think this is actually a defect; if you're only reporting the "main" version of Firefox and not the point releases, the fragment should be

Firefox/50

not

Firefox/50.0

That way, it is still accurate (...enough) but also not giving bad information; saying that its running 50.0 when in fact it is running 50.1

For what it's worth, I think not reporting the full version of Firefox is a bad idea - it adds absolutely miniscule benefit to the user, while also stopping them receiving more significant benefits, but I understand this probably isn't the place to debate it.

Either way, if Firefox is only going to report the main version number, the fragment shouldn't be misleading by including the ".0" when it isn't necessarily a .0 release.

Can we agree to fix this please.
(In reply to whatismybrowser from comment #3)
> I still think this is actually a defect; if you're only reporting the "main"
> version of Firefox and not the point releases, the fragment should be
> 
> Firefox/50
> 
> not
> 
> Firefox/50.0

Unfortunately it will break some silly version sniffers. So we have no choice. We couldn't even remove the silly "20100101" from the user-agent string.
You need to log in before you can comment on or make changes to this bug.