Closed Bug 1324556 Opened 3 years ago Closed 3 years ago

new message keyboard shortcut not working

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.46 Branch
Unspecified
macOS
defect
Not set

Tracking

(seamonkey2.48 wontfix, seamonkey2.49esr fixed, seamonkey2.50 wontfix, seamonkey2.51 wontfix, seamonkey2.52 wontfix, seamonkey2.53 fixed, seamonkey2.54 fixed)

RESOLVED FIXED
seamonkey2.54
Tracking Status
seamonkey2.48 --- wontfix
seamonkey2.49esr --- fixed
seamonkey2.50 --- wontfix
seamonkey2.51 --- wontfix
seamonkey2.52 --- wontfix
seamonkey2.53 --- fixed
seamonkey2.54 --- fixed

People

(Reporter: long, Assigned: frg)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Build ID: 20161005021738

Steps to reproduce:

Create new profile.
Start new profile in safe mode.
Press Shift+Command+M



Actual results:

Nothing other than sometimes the Tools menu flashes, other times the File menu.


Expected results:

A new message composition window opens.
I'm 98% sure this was working fine in SM 2.40
Works under Windows with Ctrl-M. Stefan could you check it on OSX.
Flags: needinfo?(stefanh)
OS: Unspecified → Mac OS X
Yeah, looks like there's a conflict with the "Responsive Design View" key here... On trunk, hitting Cmd+Shift+M when the browser window is in front, I get this:
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: aWindow.gBrowser.getBrowserContainer is not a function
Full stack: ResponsiveUI@resource://devtools/client/responsivedesign/responsivedesign.jsm:172:20
Manager.openIfNeeded<@resource://devtools/client/responsivedesign/responsivedesign.jsm:79:12
_run@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:311:39
TaskImpl@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:273:3
asyncFunction@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:247:14
toggle@resource://devtools/client/responsivedesign/responsivedesign.jsm:65:7
toggle@chrome://navigator/content/webDeveloperOverlay.js:18:5
oncommand@chrome://navigator/content/navigator.xul:1:1

*************************

Now, looking at https://dxr.mozilla.org/comm-central/rev/9dff59feff428451f3cbf5d3fe0b7934153558d1/suite/browser/webDeveloperOverlay.xul#102 and https://dxr.mozilla.org/comm-central/rev/9dff59feff428451f3cbf5d3fe0b7934153558d1/suite/locales/en-US/chrome/browser/webDeveloper.dtd#22 the conflict is obvious. The funny thing is that the shortcut shown in the menuitem is Cmd+Alt+M which I guess comes from https://dxr.mozilla.org/mozilla-central/rev/1156db49e976173fc3cf90d2126456fd1e2bae4b/devtools/client/menus.js#140
Flags: needinfo?(stefanh)
Btw, the "new Message" shortcut works when the mail window is in front.
Status: UNCONFIRMED → NEW
Ever confirmed: true
A quick fix is to just remove the modifiers at https://dxr.mozilla.org/comm-central/rev/9dff59feff428451f3cbf5d3fe0b7934153558d1/suite/browser/webDeveloperOverlay.xul#102 (the menuitem "Responsive Design View" doesn't work at all for me, so it's no loss...).
Philip, see comment #3 and comment #5 - do you have any other suggestions?
Flags: needinfo?(philip.chee)
(In reply to Stefan [:stefanh] from comment #5)
> A quick fix is to just remove the modifiers at
> https://dxr.mozilla.org/comm-central/rev/
> 9dff59feff428451f3cbf5d3fe0b7934153558d1/suite/browser/webDeveloperOverlay.
> xul#102 (the menuitem "Responsive Design View" doesn't work at all for me,
> so it's no loss...).
Well yeah lets kill the "Responsive Design View" until we have a working RDV.
Flags: needinfo?(philip.chee)
Keyboard shortcut still not working in 2.48
Attached patch 1373374-quotationmarks.patch (obsolete) — Splinter Review
Sorry I lost track of this. I will see that it gets into 2.49.1
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attachment #8895903 - Flags: review?(stefanh)
oops wrong patch
Attachment #8895903 - Attachment is obsolete: true
Attachment #8895903 - Flags: review?(stefanh)
Attachment #8895905 - Flags: review?(stefanh)
Comment on attachment 8895905 [details] [diff] [review]
1324556-resonsiveUIKey.patch

> Sorry I lost track of this. I will see that it gets into 2.49.1

-<!ENTITY responsiveDesignTool.commandkey "M">

You might want to keep the above for 2.49 / comm-beta to keep localizers happy.
Attachment #8895905 - Flags: review?(stefanh) → review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/84238bbd07ce
Remove command key for Responsive Design View. r=stefanh
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.54
Comment on attachment 8895905 [details] [diff] [review]
1324556-resonsiveUIKey.patch

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: new mail not opening on OSX using command key for it.
Testing completed (on m-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): trivial issue.
String changes made by this patch: none. push can be made without changes in webDeveloper.dtd
Attachment #8895905 - Flags: approval-comm-esr52?
Attachment #8895905 - Flags: approval-comm-beta?
Comment on attachment 8895905 [details] [diff] [review]
1324556-resonsiveUIKey.patch

a=me
Attachment #8895905 - Flags: approval-comm-esr52?
Attachment #8895905 - Flags: approval-comm-esr52+
Attachment #8895905 - Flags: approval-comm-beta?
Attachment #8895905 - Flags: approval-comm-beta+
Duplicate of this bug: 1414112
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/bf911482c679
Remove undefined command key for Responsive Design View. r=frg

Followup in Comment 17 and 18:
https://hg.mozilla.org/releases/comm-esr60/rev/6f606bccc2528de8f4e3828acedfa4e464e930cc
Remove undefined command key for Responsive Design View. r=frg a=frg

You need to log in before you can comment on or make changes to this bug.