Closed Bug 1324662 Opened 6 years ago Closed 5 years ago

Response of loading PDF pages in the second tab is much slower than the first page

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: atsai, Unassigned)

References

Details

User Story

User should be able to launch PDF via browser tabs no matter which tab or when a user want to load a PDF file. The loading behavior should be consistent and responsiveness.
PDF files cannot be loaded successfully in the second tab

STR:
1. Launch Firefox
2. load a PDF file
3. open another tab
4. load a PDF file

Expected Result:
1. Firefox is launched successfully
2. PDF file is loaded and displayed correctly
3. New tab is created
4. PDF file is loaded and displayed correctly

Actually Result:
4. PDF file isn't loaded correctly.
Severity: normal → critical
More information:

The page is displayed correctly after a long waiting. It seems we'll need to consider this as a performance milestone.
Severity: critical → normal
Blocks: 1286791
No longer blocks: 1286791
Severity: normal → critical
User Story: (updated)
Severity: critical → normal
Summary: Cannot load PDF pages in the second tab → Response of loading PDF pages in the second tab is much slower than the first page
Could you provide your test samples? Thanks.
Flags: needinfo?(atsai)
It doesn't have to be a specific PDF to reproduce the problem. Here's a PDF sample link for you to test. Since the file is larger, it'll be easier to observe.

http://www.adobe.com/content/dam/Adobe/en/devnet/acrobat/pdfs/pdf_reference_1-7.pdf
Flags: needinfo?(atsai)
Blocks: 1286791
No longer blocks: 1264551
Group: mozilla-employee-confidential
I can't reproduce this issue with the latest build.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.