Failure in 2.0.0/deqp/functional/gles3/texturestatequery.html

RESOLVED FIXED in Firefox 51

Status

()

defect
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jgilbert, Assigned: jgilbert)

Tracking

unspecified
mozilla53
Unspecified
All
Points:
---

Firefox Tracking Flags

(firefox51 fixed, firefox52 fixed, firefox53 fixed)

Details

(Whiteboard: gfx-noted)

Attachments

(1 attachment)

Assignee

Description

3 years ago
No description provided.

Comment 2

3 years ago
mozreview-review
Comment on attachment 8820196 [details]
Bug 1324721 - Coersion of GLFloat to GLint in TexParameter should round. -

https://reviewboard.mozilla.org/r/99726/#review100142

::: dom/canvas/WebGLTexture.cpp:1028
(Diff revision 1)
>                             GLfloat* maybeFloatParam)
>  {
>      MOZ_ASSERT(maybeIntParam || maybeFloatParam);
>  
> -    GLint   intParam   = maybeIntParam   ? *maybeIntParam   : GLint(*maybeFloatParam);
> +    GLint   intParam   = maybeIntParam   ? *maybeIntParam   : GLint(roundf(*maybeFloatParam));
>      GLfloat floatParam = maybeFloatParam ? *maybeFloatParam : GLfloat(*maybeIntParam);

It looks like more make sense, but I am curious if there is any bug because of this. Ideally, we should not allow params to be float when we are sure the pname uses an int param.
Assignee

Comment 3

3 years ago
(In reply to Daosheng Mu[:daoshengmu] from comment #2)
> Comment on attachment 8820196 [details]
> Bug 1324721 - Coersion of GLFloat to GLint in TexParameter should round. -
> 
> https://reviewboard.mozilla.org/r/99726/#review100142
> 
> ::: dom/canvas/WebGLTexture.cpp:1028
> (Diff revision 1)
> >                             GLfloat* maybeFloatParam)
> >  {
> >      MOZ_ASSERT(maybeIntParam || maybeFloatParam);
> >  
> > -    GLint   intParam   = maybeIntParam   ? *maybeIntParam   : GLint(*maybeFloatParam);
> > +    GLint   intParam   = maybeIntParam   ? *maybeIntParam   : GLint(roundf(*maybeFloatParam));
> >      GLfloat floatParam = maybeFloatParam ? *maybeFloatParam : GLfloat(*maybeIntParam);
> 
> It looks like more make sense, but I am curious if there is any bug because
> of this. Ideally, we should not allow params to be float when we are sure
> the pname uses an int param.

The spec mandates we accept into both entrypoints, so this is the best it can be. Please re-review.
Flags: needinfo?(dmu)
Assignee

Comment 4

3 years ago
Given how time-sensitive these patches are, I'm going to land this pre-emptively.

Comment 5

3 years ago
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/abb9dd41410e
Coersion of GLFloat to GLint in TexParameter should round. - r=daoshengmu

Comment 6

3 years ago
mozreview-review
Comment on attachment 8820196 [details]
Bug 1324721 - Coersion of GLFloat to GLint in TexParameter should round. -

https://reviewboard.mozilla.org/r/99726/#review100144
Attachment #8820196 - Flags: review?(dmu) → review+
Reviewed
Flags: needinfo?(dmu)

Comment 8

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/abb9dd41410e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Assignee

Comment 9

3 years ago
Comment on attachment 8820196 [details]
Bug 1324721 - Coersion of GLFloat to GLint in TexParameter should round. -

Approval Request Comment
[Feature/Bug causing the regression]: webgl2
[User impact if declined]:
[Is this code covered by automated tests?]:
[Has the fix been verified in Nightly?]:
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]:
[Why is the change risky/not risky?]:
[String changes made/needed]:
Attachment #8820196 - Flags: approval-mozilla-beta?
Attachment #8820196 - Flags: approval-mozilla-aurora?
Comment on attachment 8820196 [details]
Bug 1324721 - Coersion of GLFloat to GLint in TexParameter should round. -

Fix WebGL2 related issue. Beta51+ & Aurora52+. Should be in 51 beta 10.
Attachment #8820196 - Flags: approval-mozilla-beta?
Attachment #8820196 - Flags: approval-mozilla-beta+
Attachment #8820196 - Flags: approval-mozilla-aurora?
Attachment #8820196 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.