Scratchpad: Pretty printing arrow functions causes broken syntax: => becomes = >

RESOLVED DUPLICATE of bug 1302058

Status

()

Firefox
Developer Tools: Scratchpad
RESOLVED DUPLICATE of bug 1302058
11 months ago
11 months ago

People

(Reporter: Patrick Hall, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20161215085501

Steps to reproduce:

1. Open the scratchpad.
2. Enter:

var f = x => x * 2;

3. Hit "Pretty Print"




Actual results:

the function is converted to:

var f = x = > x * 2;




Expected results:

There shouldn't be a space in the arrow: =>, not = >.
(Reporter)

Updated

11 months ago
Component: Untriaged → Developer Tools: Scratchpad

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1302058
You need to log in before you can comment on or make changes to this bug.