ESEDBReader:Got error -1032 calling GetDatabaseFileInfoW when importing from Edge while opened

RESOLVED INVALID

Status

()

Firefox
Migration
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

53 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

(URL)

(Reporter)

Description

a year ago
When you attempt to migrate data from Edge into FX while Edge is opened/running, you'll receive several errors under the browser console which I listed below. I'm not sure if this is an issue or expected behaviour as I'm sure some files are being locked/used by Edge when FX tries to import them. However, when importing data from Edge while it's opened, you'll notice that sometimes the "Import Settings and Data" wizard under will get into a "Not Responding" state and will appear like the wizard is crashing. Once the import is completed, it returns to it's normal state. I never use Edge, so I barely have anything to import and it still took several seconds. It might be even longer for users with months of data to migrate and a slower machine.

STR:

* Open Edge under Win 10
** I left the "MSN" home page opened and minimized the browser
* install the latest version of m-c and complete the installation
* select "Microsoft Edge" from the "Import Settings and Data" wizard portion of the installation and select "Next"

Example: https://youtu.be/nN3EANYEELc

Errors being displayed under browser console:
=============================================

ESEDBReader:Got error -1032 calling GetDatabaseFileInfoW  ESEDBReader.jsm:148
Failed to check for table Favorites in Edge database at C:\Users\kjozwiak\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\AC\MicrosoftEdge\User\Default\DataStore\Data\\nouser1\120712-0049\DBStore\spartan.edb due to the following error: Error: Unknown error: -1032  EdgeProfileMigrator.js:256
	_checkTableExists resource://app/components/EdgeProfileMigrator.js:256:7
	get exists resource://app/components/EdgeProfileMigrator.js:241:35
	EdgeProfileMigrator.prototype.getResources resource://app/components/EdgeProfileMigrator.js:411:7
	PMB__getMaybeCachedResources resource:///modules/MigrationUtils.jsm:419:44
	get sourceExists resource:///modules/MigrationUtils.jsm:395:25
	MU_getMigrator resource:///modules/MigrationUtils.jsm:677:7
	MU_startupMigrator resource:///modules/MigrationUtils.jsm:896:20
	bound MU_startupMigrator self-hosted:933:17
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIProperties.get]  XULStore.js:66

ESEDBReader:Got error -1032 calling GetDatabaseFileInfoW  ESEDBReader.jsm:148
Failed to extract items from table ReadingList in Edge database at C:\Users\kjozwiak\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\AC\MicrosoftEdge\User\Default\DataStore\Data\\nouser1\120712-0049\DBStore\spartan.edb due to the following error: Error: Unknown error: -1032  EdgeProfileMigrator.js:81
	readTableFromEdgeDB resource://app/components/EdgeProfileMigrator.js:81:5
	EdgeReadingListMigrator.prototype._migrateReadingList< resource://app/components/EdgeProfileMigrator.js:195:28
	next self-hosted:1134:9
	TaskImpl_run resource://gre/modules/Task.jsm:319:42
	TaskImpl resource://gre/modules/Task.jsm:277:3
	asyncFunction resource://gre/modules/Task.jsm:252:14
	migrate resource://app/components/EdgeProfileMigrator.js:166:5
	MP_migrate/doMigrate< resource:///modules/MigrationUtils.jsm:324:13
	next self-hosted:1134:9
	TaskImpl_run resource://gre/modules/Task.jsm:319:42
	bound TaskImpl_run self-hosted:971:17
	MU_showMigrationWizard resource:///modules/MigrationUtils.jsm:846:5
	MU_startupMigrator resource:///modules/MigrationUtils.jsm:940:5
	bound MU_startupMigrator self-hosted:933:17

Unknown error: -1032  ESEDBReader.jsm:151
	handleESEError/< resource://app/modules/ESEDBReader.jsm:151:15
	_internalOpen resource://app/modules/ESEDBReader.jsm:272:7
	_init resource://app/modules/ESEDBReader.jsm:266:5
	ESEDB resource://app/modules/ESEDBReader.jsm:246:3
	openDB resource://app/modules/ESEDBReader.jsm:581:12
	readTableFromEdgeDB resource://app/components/EdgeProfileMigrator.js:68:16
	EdgeReadingListMigrator.prototype._migrateReadingList< resource://app/components/EdgeProfileMigrator.js:195:28
	next self-hosted:1134:9
	TaskImpl_run resource://gre/modules/Task.jsm:319:42
	TaskImpl resource://gre/modules/Task.jsm:277:3
	asyncFunction resource://gre/modules/Task.jsm:252:14
	migrate resource://app/components/EdgeProfileMigrator.js:166:5
	MP_migrate/doMigrate< resource:///modules/MigrationUtils.jsm:324:13
	next self-hosted:1134:9
	TaskImpl_run resource://gre/modules/Task.jsm:319:42
	bound TaskImpl_run self-hosted:971:17
	MU_showMigrationWizard resource:///modules/MigrationUtils.jsm:846:5
	MU_startupMigrator resource:///modules/MigrationUtils.jsm:940:5
	bound MU_startupMigrator self-hosted:933:17
some cookies did not successfully migrate.

Comment 1

a year ago
I don't think there's anything we can do against this without switching to an external library that can read these types of DBs while they're in use, which is something the Windows API doesn't let you do normally speaking, which is why we get these errors. We do tell users to close Edge.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.