Closed Bug 13249 Opened 20 years ago Closed 20 years ago

Problems with the File menu

Categories

(SeaMonkey :: General, defect, P3, major)

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 14945

People

(Reporter: cpratt, Assigned: german)

Details

Build ID: 1999-09-07 (Linux and Win32)

- There are two items in the File menu which have to do with opening files. I
believe that there should be only one item that opens files in that menu: File |
Open, or File | Open File or Location (depending on what the Netscape UI team
come up with).

- The keyboard shortcut displayed for 'Open Web Location' (sic) is Ctrl-X. This
cannot be used as X is already used by Cut. Perhaps you mean to implement
Ctrl-L, which,  although not used in Communicator 4.x, was AFAIK used in older
Netscape browsers as a shortcut for Open URL.
QA Contact: claudius → cpratt
Assignee: shuang → german
re assign it to german for clarification on "File menu" issue.
Status: NEW → ASSIGNED
We decided some time ago to split this dialog into two since the meshing of both
OS file access and typing a URL caused more UE complexity than necessary. Also
the 4.x way of opening a getFileDialog on top of the open dialog was an evil
design as we try to avoid stacking dialogs on tp of each where possible.
The ctrl-x shortcut is by mistake and will be corrected soon. Expect the
keyboard shortcut spec next week.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 14945 ***
Status: RESOLVED → VERIFIED
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.