postscript printing fails on printers which only support PS level 2

VERIFIED INVALID

Status

()

Core
Printing: Output
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Gerhard Franke, Assigned: dcone (gone))

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; de-AT; rv:0.9.9) Gecko/20020312
BuildID:    none, home made, (Mozilla/5.0 (X11; U; SunOS sun4u; de-AT; rv:0.9.9)
Gecko/20020312)

The produced postscript output seems to be broken.
If I want to print somethting, my printer receives the data and then goes into
an error state:

Mar 15 08:18:54 192.168.187.11  printer: connection with 212.201.18.82 aborted 
                    
Mar 15 08:18:55 192.168.187.11  printer: offline or intervention needed        
                    

But if I convert the produced output (mozilla.ps) with ps2ps from ghostscript
and send the result to the printer it prints without errors.

NB: Postscript printing via ghostscript works as expected.

Reproducible: Always
Steps to Reproduce:
1.Print to postscript printer HP Laserjet 2200 DN
2.
3.
(Reporter)

Comment 1

17 years ago
The problem seems to be, that the LaserJet only understands Postscript Level 2
while Mozilla produces Postscript Level 3 output. I added ps2ps to my
printfilter so the LaserJet now gets Postscript Level 2 code from mozilla.

It would be nice, if one can select the PS-Level like in Adobes Acrobat-Reader.

Comment 2

17 years ago
Confirming...
... we need to implement a prefs to a force PS Level-2 only mode in the
PostScript module or we will not be able to print on many many printers...

Over to dcone...
Assignee: rods → dcone
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: SunOS → Linux
Hardware: Sun → All

Updated

17 years ago
Summary: postscript printing fails on HP Laserjet 2200 DN → postscript printing fails on printers which only support PS level 2
(Reporter)

Comment 3

17 years ago
I rechecked the whole thing by printing mozilla.ps via the HP JetDirect ftp
interface. No errors anymore. Now it seems to be a Redhat-Printfilter problem
(the Redhat box is^Wwas the printserver for our SunRays).

Sorry for the inconvenience caused 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 4

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.