"google" is missing as a valid source for utm_source, for the Stub Attribution service whitelist

VERIFIED FIXED

Status

Cloud Services
Operations
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: stephend, Assigned: oremj)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
"google" isn't in https://bugzilla.mozilla.org/show_bug.cgi?id=1306457#c11 (so didn't make it to the Stub Attribution service whitelist, in https://github.com/mozilla-services/stubattribution/pull/23).

I found this today while testing, as I got the following exception[0]:

could not validate attribution_code: source%3Dgoogle%26medium%3Dpaidsearch%26campaign%3DBrand-US-GGL-Exact%26content%3D%28not+set%29%26timestamp%3D1482364920: source: google is not in whitelist

need-info?-ing :cmore to r? adding in "google", as by my testing, utm_source=google is a real value:

https://www.mozilla.org/en-US/firefox/new/?utm_source=google&utm_medium=paidsearch&utm_campaign=Brand-US-GGL-Exact&utm_term=download%20firefox&gclid=CjwKEAiA7ejCBRDlp8uF6ezPnjoSJAAPED7My_2tGZg1oeorhGcYkrARWn1mQMWpEaIzUq3yJwcJphoCS6Hw_wcB

[0] https://sentry.prod.mozaws.net/operations/stub_attribution-dev/issues/375124/
Flags: needinfo?(chrismore.bugzilla)
(Assignee)

Updated

a year ago
Assignee: nobody → oremj
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(chrismore.bugzilla)
Resolution: --- → FIXED
(Reporter)

Comment 1

a year ago
Verified FIXED; thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.