Intermittent TEST-UNEXPECTED-FAIL | leakcheck | default process: 20354 bytes leaked (BackstagePass, CacheEntry, CacheEntryHandle, CacheFile, CacheFileHandle, ...) in mochitest-plain dom/xhr/tests

RESOLVED DUPLICATE of bug 1325438

Status

()

RESOLVED DUPLICATE of bug 1325438
2 years ago
2 years ago

People

(Reporter: ahal, Assigned: shawnjohnjr)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
https://public-artifacts.taskcluster.net/EtqVvPsiTRyIAmhVfXyuWw/0/public/logs/live_backing.log

We discovered mochitest leakchecks were broken for a period of time and this leak may have snuck in. It appears to be intermittent, though I'm not sure of the frequency.

Bug 1325148 will fix the test harness as well as add some permafailing leaks to a whitelist (so the fix can be landed ASAP). I won't add this to the whitelist just yet, but can do so if the frequency here is too high.
Shawn, we need your assistance here. :) Though there's no data to indicate the frequency yet, I think it's worth we investigate it a bit. Thank you!
Flags: needinfo?(shuang)
Assignee: nobody → shuang
Flags: needinfo?(shuang)

Updated

2 years ago
See Also: → bug 1325438
as for the frequency, this is what I believe to be a perma fail- we were not displaying the results due to a bug in the log summarization (we overlooked leaks) and a small number of leaks exist.

in bug 1325438, it is mentioned this is linux 32 debug non e10s, that should help focus the investigation.
I still cannot reproduce this bug locally after applying patches. Is there any chance to get cc log?
what is needed for a CC log?  is this an environment variable or some preference to the browser?
(In reply to Joel Maher ( :jmaher) from comment #4)
> what is needed for a CC log?  is this an environment variable or some
> preference to the browser?
I think adding these environment variables should dump cc logs
  export MOZ_CC_LOG_DIRECTORY=/file_path
  export MOZ_CC_LOG_SHUTDOWN=1
  export MOZ_CC_RUN_DURING_SHUTDOWN=1
(Reporter)

Comment 6

2 years ago
Bug 1325438 is a dupe of this, but I'll close this one because the other bug got referenced in the whitelist that landed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1325438
You need to log in before you can comment on or make changes to this bug.