Perma leak in mochitest toolkit/components/prompts/test on OSX

RESOLVED FIXED in Firefox 53

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ahal, Assigned: mccr8)

Tracking

unspecified
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox51+, firefox52+ unaffected, firefox53+ fixed)

Details

Attachments

(1 attachment)

https://archive.mozilla.org/pub/firefox/try-builds/ahalberstadt@mozilla.com-f61c0a38a8e1ce2077a25c9ab38c22fa33147c4a/try-macosx64-debug/try_yosemite_r7-debug_test-mochitest-5-bm108-tests1-macosx-build2536.txt.gz

Mochitest jobs haven't been turning orange for leaks and no one noticed for awhile. This is one of the leaks that slipped in in the meantime. Bug 1325148 will both land the fix to the test harness as well as whitelist this leak in the mochitest harness (leakchecking for the toolkit/components/prompts/test directory will be temporarily disabled).

So this won't show up on treeherder, but it still exists and the problem will need to be identified.
[Tracking Requested - why for this release]: Leaks are bad

We seem to be leaking all sorts of stuff including XHR objects and whatnot.

It's possible this is related to the other XHR leaks we've been finding since the checking got turned back on, I guess.

Setting tracking flags based on where this could be happening.  Need to figure out where it's actually happening, plus regression range and whatnot...
I'm going to guess that this has been fixed by some other stuff. I'll do a try push and confirm.
Assignee: nobody → continuation
try looks green:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=3849a1a97ccf3f54be185427b446e5f6c06a903a

This is intended to land on top of bug 1326456, which removes the other last suppression from this list.
Comment on attachment 8825176 [details]
Bug 1325275 - Re-enable leak testing on OSX in the prompts directory.

https://reviewboard.mozilla.org/r/103378/#review104276

Awesome, thanks so much for going through all of these and fixing/closing them out! I'll file a new bug to remove the whitelist hack from the test harness once this has landed.
Attachment #8825176 - Flags: review?(ahalberstadt) → review+
Pushed by amccreight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/25ea6f3794c3
Re-enable leak testing on OSX in the prompts directory. r=ahal
https://hg.mozilla.org/mozilla-central/rev/25ea6f3794c3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.